Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Simple Python wrapper around the OpenSSL library" |
| 2 | HOMEPAGE = "https://pyopenssl.org/" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 5 | |
| 6 | DEPENDS += "openssl ${PYTHON_PN}-cryptography" |
| 7 | |
| 8 | SRC_URI[sha256sum] = "660b1b1425aac4a1bea1d94168a85d99f0b3144c869dd4390d27629d0087f1bf" |
| 9 | |
| 10 | PYPI_PACKAGE = "pyOpenSSL" |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | PACKAGES =+ "${PN}-tests" |
| 14 | FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test" |
| 15 | |
| 16 | RDEPENDS:${PN}:class-target = " \ |
| 17 | ${PYTHON_PN}-cryptography \ |
| 18 | ${PYTHON_PN}-six \ |
| 19 | ${PYTHON_PN}-threading \ |
| 20 | " |
| 21 | RDEPENDS:${PN}-tests = "${PN}" |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |