Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Provides support for the Tag Image File Format (TIFF)" |
| 2 | LICENSE = "BSD-2-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf" |
| 4 | |
| 5 | CVE_PRODUCT = "libtiff" |
| 6 | |
| 7 | SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \ |
| 8 | file://libtool2.patch \ |
| 9 | file://CVE-2017-9935.patch \ |
| 10 | file://CVE-2017-18013.patch \ |
| 11 | file://CVE-2018-5784.patch \ |
Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 12 | file://CVE-2018-10963.patch \ |
| 13 | file://CVE-2018-8905.patch \ |
| 14 | file://CVE-2018-7456.patch \ |
Brad Bishop | 004d499 | 2018-10-02 23:54:45 +0200 | [diff] [blame] | 15 | file://CVE-2017-17095.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | SRC_URI[md5sum] = "54bad211279cc93eb4fca31ba9bfdc79" |
| 19 | SRC_URI[sha256sum] = "6e7bdeec2c310734e734d19aae3a71ebe37a4d842e0e23dbb1b8921c0026cfcd" |
| 20 | |
| 21 | # exclude betas |
| 22 | UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar" |
| 23 | |
| 24 | inherit autotools multilib_header |
| 25 | |
| 26 | CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no" |
| 27 | |
| 28 | PACKAGECONFIG ?= "cxx jpeg zlib lzma \ |
| 29 | strip-chopping extrasample-as-alpha check-ycbcr-subsampling" |
| 30 | |
| 31 | PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,," |
| 32 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg," |
| 33 | PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib," |
| 34 | PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz," |
| 35 | |
| 36 | # Convert single-strip uncompressed images to multiple strips of specified |
| 37 | # size (default: 8192) to reduce memory usage |
| 38 | PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,," |
| 39 | |
| 40 | # Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA |
| 41 | PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,," |
| 42 | |
| 43 | # Control picking up YCbCr subsample info. Disable to support files lacking |
| 44 | # the tag |
| 45 | PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,," |
| 46 | |
| 47 | # Support a mechanism allowing reading large strips (usually one strip files) |
| 48 | # in chunks when using TIFFReadScanline. Experimental 4.0+ feature |
| 49 | PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,," |
| 50 | |
| 51 | PACKAGES =+ "tiffxx tiff-utils" |
| 52 | FILES_tiffxx = "${libdir}/libtiffxx.so.*" |
| 53 | FILES_tiff-utils = "${bindir}/*" |
| 54 | |
| 55 | do_install_append() { |
| 56 | oe_multilib_header tiffconf.h |
| 57 | } |
| 58 | |
| 59 | BBCLASSEXTEND = "native" |