Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | require automake.inc |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 4 | DEPENDS_class-native = "autoconf-native" |
| 5 | |
| 6 | NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}" |
| 7 | |
| 8 | RDEPENDS_${PN} += "\ |
| 9 | autoconf \ |
| 10 | perl \ |
| 11 | perl-module-bytes \ |
| 12 | perl-module-data-dumper \ |
| 13 | perl-module-strict \ |
| 14 | perl-module-text-parsewords \ |
| 15 | perl-module-thread-queue \ |
| 16 | perl-module-threads \ |
| 17 | perl-module-vars " |
| 18 | |
| 19 | RDEPENDS_${PN}_class-native = "autoconf-native hostperl-runtime-native" |
| 20 | RDEPENDS_${PN}_class-nativesdk = "nativesdk-autoconf" |
| 21 | |
| 22 | SRC_URI += "file://python-libdir.patch \ |
| 23 | file://buildtest.patch \ |
| 24 | file://performance.patch \ |
| 25 | file://new_rt_path_for_test-driver.patch \ |
| 26 | file://automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch \ |
| 27 | file://0001-automake-Add-default-libtool_tag-to-cppasm.patch \ |
| 28 | file://0001-build-fix-race-in-parallel-builds.patch \ |
| 29 | " |
| 30 | |
| 31 | SRC_URI[md5sum] = "83cc2463a4080efd46a72ba2c9f6b8f5" |
| 32 | SRC_URI[sha256sum] = "608a97523f97db32f1f5d5615c98ca69326ced2054c9f82e65bade7fc4c9dea8" |
| 33 | |
| 34 | PERL = "${USRBINPATH}/perl" |
| 35 | PERL_class-native = "${USRBINPATH}/env perl" |
| 36 | PERL_class-nativesdk = "${USRBINPATH}/env perl" |
| 37 | |
| 38 | CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'" |
| 39 | |
| 40 | do_install_append () { |
| 41 | install -d ${D}${datadir} |
| 42 | } |
| 43 | |
| 44 | BBCLASSEXTEND = "native nativesdk" |