blob: 9e77766e6200acc871ffb1f1a6aaeacaf28c8407 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "The NTFS-3G driver is an open source, freely available NTFS driver for Linux with read and write support."
2HOMEPAGE = "http://www.ntfs-3g.org/"
3DEPENDS = "fuse libgcrypt"
4PROVIDES = "ntfsprogs ntfs-3g"
5LICENSE = "GPLv2 & LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
8
9SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz \
10 file://0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch \
11"
12S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}"
13SRC_URI[md5sum] = "d97474ae1954f772c6d2fa386a6f462c"
14SRC_URI[sha256sum] = "3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5"
15
16inherit autotools pkgconfig
17
18PACKAGECONFIG ??= ""
19PACKAGECONFIG[uuid] = "--with-uuid,--without-uuid,util-linux"
20
21# required or it calls ldconfig at install step
22EXTRA_OEMAKE = "LDCONFIG=echo"
23
24PACKAGES =+ "ntfs-3g ntfsprogs libntfs-3g"
25
26FILES_ntfs-3g = "${base_sbindir}/*.ntfs-3g ${bindir}/ntfs-3g* ${base_sbindir}/mount.ntfs"
27RDEPENDS_ntfs-3g += "fuse"
28RRECOMMENDS_ntfs-3g = "util-linux-mount"
29
30FILES_ntfsprogs = "${base_sbindir}/* ${bindir}/* ${sbindir}/*"
31FILES_libntfs-3g = "${libdir}/*${SOLIBS}"
32
33do_install_append() {
34 # Standard mount will execute the program /sbin/mount.TYPE
35 # when called. Add the symbolic to let mount could find ntfs.
36 ln -sf mount.ntfs-3g ${D}/${base_sbindir}/mount.ntfs
37 rmdir ${D}${libdir}/ntfs-3g
38}
39
40# Satisfy the -dev runtime dependency
41ALLOW_EMPTY_${PN} = "1"