blob: d7887635e08b17568fecee0c49703f09e88f6490 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "The CAPS Audio Plugin Suite - LADSPA plugin suite"
2HOMEPAGE = "http://quitte.de/dsp/caps.html"
3LICENSE = "GPL-3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006SRC_URI = "http://quitte.de/dsp/${PN}_${PV}.tar.bz2 \
7 file://Avoid-ambiguity-in-div-invocation.patch \
8 file://0001-basic.h-Use-c99-supported-stdint-types.patch \
9 file://append_ldflags.patch \
10 "
Patrick Williamsddad1a12017-02-23 20:36:32 -060011
12SRC_URI[md5sum] = "c1d634038dcb54702306c0e30cb1c626"
13SRC_URI[sha256sum] = "f746feba57af316b159f0169de5d78b4fd1064c2c0c8017cb5856b2f22e83f20"
14
15S = "${WORKDIR}/${PN}-${PV}"
16
17EXTRA_OEMAKE = " \
18 CC='${CXX}' \
19 CFLAGS='${CFLAGS} -ffast-math -funroll-loops -fPIC -DPIC' \
20"
21do_compile() {
22 oe_runmake all
23}
24
25do_install() {
26 install -Dm 0644 caps.so ${D}${libdir}/ladspa/caps.so
27}
28
29FILES_${PN} = "${libdir}/ladspa/"