blob: 8890e14318f2b26fcecb81faf29a9bc372a3791a [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Dibbler DHCPv6 client"
2DESCRIPTION = "Dibbler is a portable DHCPv6 implementation. It supports stateful as well as stateless autoconfiguration for IPv6."
3HOMEPAGE = "http://klub.com.pl/dhcpv6"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=7236695bb6d4461c105d685a8b61c4e3"
7
8SRCREV = "c4b0ed52e751da7823dd9a36e91f93a6310e5525"
9
10SRC_URI = "git://github.com/tomaszmrugalski/dibbler \
11 file://dibbler_fix_getSize_crash.patch \
12 "
13PV = "1.0.1+1.0.2RC1+git${SRCREV}"
14
15S = "${WORKDIR}/git"
16
17PACKAGECONFIG ??= "debug bind-reuse resolvconf dns-update"
18
19PACKAGECONFIG[debug] = "--enable-debug,,,"
20PACKAGECONFIG[efence] = "--enable-efence,,,"
21PACKAGECONFIG[bind-reuse] = "--enable-bind-reuse,,,"
22PACKAGECONFIG[dst-addr-filter] = "--enable-dst-addr-check,,,"
23PACKAGECONFIG[resolvconf] = "--enable-resolvconf,,,"
24PACKAGECONFIG[dns-update] = "--enable-dns-update,,,"
25PACKAGECONFIG[auth] = "--enable-auth,,,"
26PACKAGECONFIG[gtest] = "--enable-gtest-static,,,"
27
28inherit autotools
29
30DEPENDS += "flex-native"
31
32PACKAGES =+ "${PN}-requestor ${PN}-client ${PN}-relay ${PN}-server"
33
34FILES_${PN}-client = "${sbindir}/${PN}-client"
35FILES_${PN}-relay = "${sbindir}/${PN}-relay"
36FILES_${PN}-requestor = "${sbindir}/${PN}-requestor"
37FILES_${PN}-server = "${sbindir}/${PN}-server"