blob: 82c25ffa6e5276ed9bc072ea4d1c465c4b61b7f4 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "wireshark - a popular network protocol analyzer"
2HOMEPAGE = "http://www.wireshark.org"
3SECTION = "net"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=6e271234ba1a13c6e512e76b94ac2f77"
6
7DEPENDS = "pcre expat glib-2.0 glib-2.0-native"
8
9SRC_URI = "https://2.na.dl.wireshark.org/src/all-versions/${BP}.tar.bz2"
10
11PE = "1"
12
13SRC_URI[md5sum] = "7d5e65efd0714bd6248aa5b36c28320d"
14SRC_URI[sha256sum] = "c8b32c0e7d44a277e737c53d9d142ad3fe4265338f25a7fd8c891f58a7633fc2"
15
16inherit autotools pkgconfig perlnative
17
18ARM_INSTRUCTION_SET = "arm"
19
20PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc"
21PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}"
22#PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gtk3", "", d)}"
23
24PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_LIBDIR}, --with-libcap=no --enable-pcap-ng-default , libcap"
25PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_LIBDIR} --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap"
26PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
27PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
28PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
29PACKAGECONFIG[gtk2] = "--with-gtk=2, , gtk+"
30PACKAGECONFIG[gtk3] = "--with-gtk=3, , gtk+3"
31PACKAGECONFIG[graphics] = "--enable-wireshark, --with-gtk=no --disable-wireshark,"
32PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
33PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt"
34PACKAGECONFIG[ssl] = "--with-ssl=yes, --with-ssl=no, openssl"
35PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5"
36PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua"
37PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib"
38PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
39PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no"
40PACKAGECONFIG[sbc] = "--with-sbc=yes, --with-sbc=no, sbc"
41
42PACKAGECONFIG[libssh] = "--with-ssh=yes, --with-ssh=no, libssh2"
43
44
45# these next two options require addional layers
46PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
47
48EXTRA_OECONF += "--with-qt=no --enable-tshark --enable-rawshark"
49
50# Currently wireshark does not install header files
51do_install_append () {
52
53 install -d ${D}/${includedir}/${BPN}
54 install -d ${D}/${includedir}/${BPN}/epan
55 install -d ${D}/${includedir}/${BPN}/epan/crypt
56 install -d ${D}/${includedir}/${BPN}/epan/dfilter
57 install -d ${D}/${includedir}/${BPN}/epan/dissectors
58 install -d ${D}/${includedir}/${BPN}/epan/ftypes
59 install -d ${D}/${includedir}/${BPN}/epan/wmem
60
61 install config.h ${D}/${includedir}/${BPN}
62 install ${S}/register.h ${D}/${includedir}/${BPN}
63 install -D ${S}/epan/*.h ${D}/${includedir}/${BPN}/epan
64 install -D ${S}/epan/crypt/*.h ${D}/${includedir}/${BPN}/epan/crypt
65 install -D ${S}/epan/dfilter/*.h ${D}/${includedir}/${BPN}/epan/dfilter
66 install -D ${S}/epan/dissectors/*.h ${D}/${includedir}/${BPN}/epan/dissectors
67 install -D ${S}/epan/ftypes/*.h ${D}/${includedir}/${BPN}/epan/ftypes
68 install -D ${S}/epan/wmem/*.h ${D}/${includedir}/${BPN}/epan/wmem
69}
70
71FILES_${PN} += "${datadir}*"