blob: c3a1eadfd8d73001fc3b90c3d0e3eb94469ae22e [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001HOMEPAGE = "http://w1.fi/hostapd/"
2SECTION = "kernel/userland"
3LICENSE = "GPLv2 | BSD"
4LIC_FILES_CHKSUM = "file://${B}/README;md5=8aa4e8c78b59b12016c4cb2d0a8db350"
5DEPENDS = "libnl openssl"
6SUMMARY = "User space daemon for extended IEEE 802.11 management"
7
8inherit update-rc.d systemd
9INITSCRIPT_NAME = "hostapd"
10
11SYSTEMD_SERVICE_${PN} = "hostapd.service"
12SYSTEMD_AUTO_ENABLE_${PN} = "disable"
13
14SRC_URI = " \
15 http://w1.fi/releases/hostapd-${PV}.tar.gz \
16 file://defconfig \
17 file://init \
18 file://hostapd.service \
19 file://key-replay-cve-multiple.patch \
20"
21
22S = "${WORKDIR}/hostapd-${PV}"
23B = "${WORKDIR}/hostapd-${PV}/hostapd"
24
25do_configure() {
26 install -m 0644 ${WORKDIR}/defconfig ${B}/.config
27}
28
29do_compile() {
30 export CFLAGS="-MMD -O2 -Wall -g -I${STAGING_INCDIR}/libnl3"
31 make
32}
33
34do_install() {
35 install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/
36 install -m 0644 ${B}/hostapd.conf ${D}${sysconfdir}
37 install -m 0755 ${B}/hostapd ${D}${sbindir}
38 install -m 0755 ${B}/hostapd_cli ${D}${sbindir}
39 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
40 install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/
41 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service
42}
43
44CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"
45
46SRC_URI[md5sum] = "eaa56dce9bd8f1d195eb62596eab34c7"
47SRC_URI[sha256sum] = "01526b90c1d23bec4b0f052039cc4456c2fd19347b4d830d1d58a0a6aea7117d"
48