blob: a953ebc28e6f9fdd2d51959cf955cc12da41da36 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "dbus forwarding daemon"
2LICENSE = "LGPLv2.1+"
3LIC_FILES_CHKSUM = "file://dbus-daemon-proxy.c;endline=19;md5=41df6d21fe1c97d6a1cc22a5bf374cba"
4DEPENDS = "dbus dbus-glib"
5SRCREV = "1226a0a1374628ff191f6d8a56000be5e53e7608"
6PV = "0.0.0+gitr${SRCPV}"
7PR = "r1"
8
9ASNEEDED_pn-dbus-daemon-proxy = ""
10
11SRC_URI = "git://git.collabora.co.uk/git/user/alban/dbus-daemon-proxy"
12S = "${WORKDIR}/git"
13
14do_compile() {
15 ${CC} ${LDFLAGS} `pkg-config --cflags --libs dbus-glib-1` -o dbus-daemon-proxy dbus-daemon-proxy.c
16}
17
18do_install() {
19 install -d ${D}${bindir}
20 install -m 0755 dbus-daemon-proxy ${D}${bindir}
21}
22
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023
24PNBLACKLIST[dbus-daemon-proxy] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130613/ - the recipe will be removed on 2017-09-01 unless the issue is fixed"