blob: 6163cff7c495f207c4b5b75ae5501c1483ea000c [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Plymouth is a project from Fedora providing a flicker-free graphical boot process."
2
3DESCRIPTION = "Plymouth is an application that runs very early in the boot process \
Patrick Williamsddad1a12017-02-23 20:36:32 -06004 (even before the root filesystem is mounted!) that provides a \
5 graphical boot animation while the boot process happens in the background. \
6"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007
8HOMEPAGE = "http://www.freedesktop.org/wiki/Software/Plymouth"
9SECTION = "base"
10
11LICENSE = "GPLv2+"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
14
15DEPENDS = "libcap libpng cairo dbus udev"
16PROVIDES = "virtual/psplash"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017RPROVIDES_${PN} = "virtual-psplash virtual-psplash-support"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018
19SRC_URI = "http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.tar.bz2"
20SRC_URI[md5sum] = "ff420994deb7ea203df678df92e7ab7d"
21SRC_URI[sha256sum] = "2f0ce82042cf9c7eadd2517a1f74c8a85fa8699781d9f294a06eade29fbed57f"
22
Patrick Williamsddad1a12017-02-23 20:36:32 -060023EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation \
24 --with-logo=${LOGO} \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \
26"
27
28PACKAGECONFIG ??= "pango initrd"
29PACKAGECONFIG_append_x86 = " drm"
30PACKAGECONFIG_append_x86-64 = " drm"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050031
32PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm"
33PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
34PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+"
Patrick Williamsddad1a12017-02-23 20:36:32 -060035PACKAGECONFIG[initrd] = ",,,"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050036
37LOGO ??= "${datadir}/plymouth/bizcom.png"
38
Patrick Williamsb48b7b42016-08-17 15:04:38 -050039inherit autotools pkgconfig systemd
40
Patrick Williamsb48b7b42016-08-17 15:04:38 -050041do_install_append() {
Patrick Williamsddad1a12017-02-23 20:36:32 -060042 install -d ${D}${systemd_unitdir}/system
43 install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system
44 install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system
45 # Remove /var/run from package as plymouth will populate it on startup
46 rm -fr "${D}${localstatedir}/run"
47
48 if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then
49 rm -rf "${D}${libexecdir}"
50 fi
Patrick Williamsb48b7b42016-08-17 15:04:38 -050051}
52
Patrick Williamsddad1a12017-02-23 20:36:32 -060053PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}"
54PACKAGES =+ "${PN}-set-default-theme"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050055
56FILES_${PN}-initrd = "${libexecdir}/plymouth/*"
57FILES_${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme"
58
59FILES_${PN} += "${systemd_unitdir}/system/*"
60FILES_${PN}-dbg += "${libdir}/plymouth/renderers/.debug"
61
62
63RDEPENDS_${PN}-initrd = "bash dracut"
64RDEPENDS_${PN}-set-default-theme = "bash"
65
66SYSTEMD_SERVICE_${PN} = "plymouth-start.service"