blob: 36c2b634963333dfdb72ac968802d16b34abf59d [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# Released under the MIT license (see COPYING.MIT for the terms)
2
3# Applications using this library needs to add link against libbreakpad_client.a.
4
5SUMMARY = "An open-source multi-platform crash reporting system"
6DESCRIPTION = "Breakpad is a library and tool suite that allows you to distribute an application to users with compiler-provided debugging information removed, record crashes in compact \"minidump\" files, send them back to your server, and produce C and C++ stack traces from these minidumps. "
7HOMEPAGE = "https://code.google.com/p/google-breakpad/"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=56c24a43c81c3af6fcf590851931489e"
10SECTION = "libs"
11
12inherit autotools
13
14BBCLASSEXTEND = "native"
15
16PE = "1"
17
18PV = "1.0+git${SRCPV}"
19
20SRCREV_FORMAT = "breakpad_glog_gmock_gtest_protobuf_lss"
21
22SRCREV_breakpad = "2f6cb866d615d6240a18c7535c994c6bb93b1ba5"
23SRCREV_glog = "d8cb47f77d1c31779f3ff890e1a5748483778d6a"
24SRCREV_gmock = "f7d03d2734759ee12b57d2dbcb695607d89e8e05"
25SRCREV_gtest = "ec44c6c1675c25b9827aacd08c02433cccde7780"
26SRCREV_protobuf = "cb6dd4ef5f82e41e06179dcd57d3b1d9246ad6ac"
27SRCREV_lss = "1549d20f6d3e7d66bb4e687c0ab9da42c2bff2ac"
28
29SRC_URI = "git://github.com/google/breakpad;name=breakpad \
30 git://github.com/google/glog.git;destsuffix=git/src/third_party/glog;name=glog \
31 git://github.com/google/googlemock.git;destsuffix=git/src/testing;name=gmock \
32 git://github.com/google/googletest.git;destsuffix=git/src/testing/gtest;name=gtest \
33 git://github.com/google/protobuf.git;destsuffix=git/src/third_party/protobuf/protobuf;name=protobuf \
34 git://chromium.googlesource.com/linux-syscall-support;protocol=https;destsuffix=git/src/third_party/lss;name=lss \
35"
36S = "${WORKDIR}/git"
37
38COMPATIBLE_MACHINE_powerpc = "(!.*ppc).*"
39
40do_install_append() {
41 install -d ${D}${includedir}
42 install -d ${D}${includedir}/breakpad
43
44 install -d ${D}${includedir}/breakpad/client/linux/crash_generation
45 install -m 0644 ${S}/src/client/linux/crash_generation/crash_generation_client.h ${D}${includedir}/breakpad/client/linux/crash_generation/crash_generation_client.h
46
47 install -d ${D}${includedir}/breakpad/client/linux/handler/
48 install -m 0644 ${S}/src/client/linux/handler/exception_handler.h ${D}${includedir}/breakpad/client/linux/handler/exception_handler.h
49 install -m 0644 ${S}/src/client/linux/handler/minidump_descriptor.h ${D}${includedir}/breakpad/client/linux/handler/minidump_descriptor.h
50
51 install -d ${D}${includedir}/breakpad/client/linux/dump_writer_common
52 install -m 0644 ${S}/src/client/linux/dump_writer_common/mapping_info.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/mapping_info.h
53 install -m 0644 ${S}/src/client/linux/dump_writer_common/thread_info.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/thread_info.h
54 install -m 0644 ${S}/src/client/linux/dump_writer_common/raw_context_cpu.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/raw_context_cpu.h
55
56 install -d ${D}${includedir}/breakpad/client/linux/minidump_writer
57 install -m 0644 ${S}/src/client/linux/minidump_writer/linux_dumper.h ${D}${includedir}/breakpad/client/linux/minidump_writer/linux_dumper.h
58 install -m 0644 ${S}/src/client/linux/minidump_writer/minidump_writer.h ${D}${includedir}/breakpad/client/linux/minidump_writer/minidump_writer.h
59
60 install -d ${D}${includedir}/breakpad/common
61 install -m 0644 ${S}/src/common/memory.h ${D}${includedir}/breakpad/common/memory.h
62 install -m 0644 ${S}/src/common/scoped_ptr.h ${D}${includedir}/breakpad/common/scoped_ptr.h
63 install -m 0644 ${S}/src/common/using_std_string.h ${D}${includedir}/breakpad/common/using_std_string.h
64
65 install -d ${D}${includedir}/breakpad/google_breakpad/common
66 install -m 0644 ${S}/src/google_breakpad/common/breakpad_types.h ${D}${includedir}/breakpad/google_breakpad/common/breakpad_types.h
67 install -m 0644 ${S}/src/google_breakpad/common/minidump_format.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_format.h
68 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_amd64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_amd64.h
69 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_arm.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_arm.h
70 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_arm.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_arm64.h
71 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_mips.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_mips.h
72 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_ppc64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_ppc64.h
73 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_ppc.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_ppc.h
74 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_sparc.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_sparc.h
75 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_x86.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_x86.h
76 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_linux.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_linux.h
77 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_mac.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_mac.h
78 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_ps3.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_ps3.h
79 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_solaris.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_solaris.h
80 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_win32.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_win32.h
81
82 install -d ${D}${includedir}/breakpad/third_party/lss
83 install -m 0644 ${S}/src/third_party/lss/linux_syscall_support.h ${D}${includedir}/breakpad/third_party/lss/linux_syscall_support.h
84}
85
86PACKAGES =+ "${PN}-minidump-upload ${PN}-sym-upload"
87
88FILES_${PN}-minidump-upload = "${bindir}/minidump_upload"
89FILES_${PN}-sym-upload = "${bindir}/sym_upload"
90
91
92SYSROOT_PREPROCESS_FUNCS += "breakpad_populate_sysroot"
93breakpad_populate_sysroot() {
94 sysroot_stage_dir ${D}/usr/include ${SYSROOT_DESTDIR}/usr/include
95 sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib
96 sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib
97}
98
99# Fails to build with thumb-1 (qemuarm)
100#| {standard input}: Assembler messages:
101#| {standard input}:2178: Error: selected processor does not support Thumb mode `it ne'
102#| {standard input}:2179: Error: Thumb does not support conditional execution
103#| {standard input}:2180: Error: selected processor does not support Thumb mode `it eq'
104#| {standard input}:2181: Error: Thumb does not support conditional execution
105#| {standard input}:2183: Error: lo register required -- `str ip,[r1,#-4]!'
106#| {standard input}:2184: Error: Thumb does not support this addressing mode -- `str r6,[r1,#-4]!'
107#| {standard input}:2191: Error: lo register required -- `ldr pc,[sp]'
108#| make: *** [src/client/linux/handler/exception_handler.o] Error 1
109ARM_INSTRUCTION_SET = "arm"