blob: cb65caad8cb73bc655e724904822f8186027244f [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "USB CEC Adaptor communication Library"
2HOMEPAGE = "http://libcec.pulse-eight.com/"
3
4LICENSE = "GPLv2+"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007DEPENDS = "p8platform udev lockdev ncurses swig-native python3"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}"
10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012PV = "4.0.1+gitr${SRCPV}"
13
14SRCREV = "2fc92b5f02dca702da92ccc5ed7b805b240ef5df"
15SRC_URI = "git://github.com/Pulse-Eight/libcec.git \
16 file://python-install-location.patch"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017
18S = "${WORKDIR}/git"
19
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020inherit cmake pkgconfig
21
22# Create the wrapper for python3
23PACKAGES += "python3-${BPN}"
24FILES_python3-${BPN} = "${libdir}/python3*"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050025
26# cec-client and xbmc need the .so present to work :(
27FILES_${PN} += "${libdir}/*.so"
28INSANE_SKIP_${PN} = "dev-so"
29
30# Adapter shows up as a CDC-ACM device
31RRECOMMENDS_${PN} = "kernel-module-cdc-acm"