blob: ac36a91a35d29a53530d9ce59ed005fd9ab88b82 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "tesseract-ocr language files"
2
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9648bd7af63bd3cc4f5ac046d12c49e4"
5
6PV = "3.04.00+git${SRCPV}"
7SRCREV = "3cf1e2df1fe1d1da29295c9ef0983796c7958b7d"
8SRC_URI = "git://github.com/tesseract-ocr/tessdata.git"
9S = "${WORKDIR}/git"
10
11inherit allarch
12
13do_install() {
14 install -d ${D}${datadir}/tessdata
15 cp -R --no-dereference --preserve=mode,links -v ${S}/*.traineddata ${S}/*.cube.* ${S}/*.tesseract_cube.* ${D}${datadir}/tessdata
16}
17
18python populate_packages_prepend () {
19 tessdata_dir= d.expand('${datadir}/tessdata')
20 pkgs = do_split_packages(d, tessdata_dir, '^([a-z_]*)\.*', '${BPN}-%s', 'tesseract-ocr language files for %s', extra_depends='')
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021 pn = d.getVar('PN')
Patrick Williamsddad1a12017-02-23 20:36:32 -060022 d.appendVar('RDEPENDS_' + pn, ' '+' '.join(pkgs))
23}
24
25PACKAGES_DYNAMIC += "^${BPN}-.*"
26ALLOW_EMPTY_${PN} = "1"