blob: de140641c59b133105ea8b6e35313190a3dc2503 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001HOMEPAGE = "https://github.com/firehol/netdata/"
2SUMMARY = "Real-time performance monitoring"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://LICENSE.md;md5=747afe070ea9d6c2be0a31353609a35b"
5
6SRC_URI = "git://github.com/firehol/netdata.git;protocol=https"
7SRCREV = "36c1304e37094174ea51001903058e65053107ca"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008PV = "1.0.1+git${SRCPV}"
Patrick Williamsddad1a12017-02-23 20:36:32 -06009
10# patch to disable timeout because timeout are not available with actual version
11# of core-utils
12SRC_URI += "file://0001-Correct-Timeout-issue.patch"
13
14# default netdata.conf for netdata configuration
15SRC_URI += "file://netdata.conf"
16
17# file for providing systemd service support
18SRC_URI += "file://netdata.service"
19
20S = "${WORKDIR}/git"
21
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022DEPENDS += "zlib"
23
Patrick Williamsddad1a12017-02-23 20:36:32 -060024inherit pkgconfig autotools useradd systemd
25
26#systemd
27SYSTEMD_PACKAGES = "${PN}"
28SYSTEMD_SERVICE_${PN} = "netdata.service"
29SYSTEMD_AUTO_ENABLE_${PN} = "enable"
30
31#User specific
32USERADD_PACKAGES = "${PN}"
33GROUPADD_PARAM_${PN} = "--system netdata"
34
35do_install_append() {
36 #set S UID for plugins
37 chmod 4755 ${D}${libexecdir}/netdata/plugins.d/apps.plugin
38
39 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
40 # Install systemd unit files
41 install -d ${D}${systemd_unitdir}/system
42 install -m 0644 ${WORKDIR}/netdata.service ${D}${systemd_unitdir}/system
43 sed -i -e 's,@@datadir,${datadir_native},g' ${D}${systemd_unitdir}/system/netdata.service
44 fi
45
46 # Install default netdata.conf
47 install -d ${D}${sysconfdir}/netdata
48 install -m 0644 ${WORKDIR}/netdata.conf ${D}${sysconfdir}/netdata/
49 sed -i -e 's,@@sysconfdir,${sysconfdir},g' ${D}${sysconfdir}/netdata/netdata.conf
50 sed -i -e 's,@@libdir,${libexecdir},g' ${D}${sysconfdir}/netdata/netdata.conf
51 sed -i -e 's,@@datadir,${datadir},g' ${D}${sysconfdir}/netdata/netdata.conf
52}
53
54FILES_${PN}-dbg += "${libexecdir}/netdata/plugins.d/.debug"
55RDEPENDS_${PN} = "bash zlib"