blob: 0e0f9ba401c3071dbc604bb7ea4b12d98a5af1fc [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001SUMMARY = "A commandline OMX player for the Raspberry Pi"
2DESCRIPTION = "This player was developed as a testbed for the XBMC \
3Raspberry PI implementation and is quite handy to use standalone"
4HOMEPAGE = "https://github.com/popcornmix/omxplayer"
5SECTION = "console/utils"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
9
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010DEPENDS = "libpcre libav virtual/egl boost freetype dbus openssl samba libssh libomxil coreutils-native curl-native"
Patrick Williams8b8bc412016-08-17 15:02:23 -050011PR = "r4"
12
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013SRCREV = "061425a5eabf6e9ee43229911c073a863d144038"
Patrick Williams8b8bc412016-08-17 15:02:23 -050014SRC_URI = "git://github.com/popcornmix/omxplayer.git;protocol=git;branch=master \
15 file://0001-Remove-Makefile.include-which-includes-hardcoded.patch \
16 file://0002-Libraries-and-headers-from-ffmpeg-are-installed-in-u.patch \
17 file://0003-Remove-strip-step-in-Makefile.patch \
18 file://0004-Add-FFMPEG_EXTRA_CFLAGS-and-FFMPEG_EXTRA_LDFLAGS.patch \
19 file://fix-tar-command-with-DIST.patch \
20 file://use-native-pkg-config.patch \
21 "
22S = "${WORKDIR}/git"
23
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024COMPATIBLE_MACHINE ?= "null"
25COMPATIBLE_MACHINE_rpi_aarch64 = "null"
26COMPATIBLE_MACHINE_rpi = "(.*)"
Patrick Williams8b8bc412016-08-17 15:02:23 -050027
28inherit autotools-brokensep pkgconfig
29
30# Needed in ffmpeg configure
31export TEMPDIR = "${S}/tmp"
32
33# Needed in Makefile.ffmpeg
34export HOST = "${HOST_SYS}"
35export WORK = "${S}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036export FFMPEG_EXTRA_CFLAGS = "${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS}"
37export FFMPEG_EXTRA_LDFLAGS = "${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS}"
Patrick Williams8b8bc412016-08-17 15:02:23 -050038
39# Needed in top Makefile
40export LDFLAGS = "-L${S}/ffmpeg_compiled/usr/lib \
41 -L${STAGING_DIR_HOST}/lib \
42 -L${STAGING_DIR_HOST}/usr/lib \
43 "
44export INCLUDES = "-isystem${STAGING_DIR_HOST}/usr/include/interface/vcos/pthreads \
45 -isystem${STAGING_DIR_HOST}/usr/include/freetype2 \
46 -isystem${STAGING_DIR_HOST}/usr/include/interface/vmcs_host/linux \
47 -isystem${STAGING_DIR_HOST}/usr/include/dbus-1.0 \
48 -isystem${STAGING_DIR_HOST}/usr/lib/dbus-1.0/include \
49 "
50export DIST = "${D}"
51
52do_compile() {
53 # Needed for compiler test in ffmpeg's configure
54 mkdir -p tmp
55
56 oe_runmake ffmpeg
57 oe_runmake
58}
59
60do_install() {
61 oe_runmake STRIP='echo skipping strip' dist
62 mkdir -p ${D}${datadir}/fonts/truetype/freefont/
63 install ${S}/fonts/* ${D}${datadir}/fonts/truetype/freefont/
64}
65
66FILES_${PN} = "${bindir}/omxplayer* \
67 ${libdir}/omxplayer/lib*${SOLIBS} \
68 ${datadir}/fonts"
69
70FILES_${PN}-dev += "${libdir}/omxplayer/*.so"
71
72RDEPENDS_${PN} += "bash procps"