blob: 4a6e8cd162c33d7b665a209e98fe31898e4df938 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001include runc.inc
2
3SRCREV = "75f8da7c889acc4509a0cf6f0d3a8f9584778375"
4SRC_URI = "git://github.com/opencontainers/runc;branch=master \
5 "
6RUNC_VERSION = "1.0.0-rc3"
7PROVIDES += "virtual/runc"
8RPROVIDES_${PN} = "virtual/runc"
9
10do_compile_prepend() {
11 # Go looks in a src directory under any directory in GOPATH but
12 # runc-opencontainers uses 'vendor' instead of 'vendor/src'. We can fix
13 # this with a symlink.
14 ln -sfn . "${S}/vendor/src"
15}