blob: 68f251cfd02b17f194e2c10a4757b2556e5723c7 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# The WICVARS variable is used to define list of bitbake variables used in wic code
2# variables from this list is written to <image>.env file
3WICVARS ?= "\
4 BBLAYERS IMGDEPLOYDIR DEPLOY_DIR_IMAGE FAKEROOTCMD IMAGE_BASENAME IMAGE_BOOT_FILES \
5 IMAGE_LINK_NAME IMAGE_ROOTFS INITRAMFS_FSTYPES INITRD INITRD_LIVE ISODIR RECIPE_SYSROOT_NATIVE \
6 ROOTFS_SIZE STAGING_DATADIR STAGING_DIR STAGING_LIBDIR TARGET_SYS TRANSLATED_TARGET_ARCH"
7
8WKS_FILE ??= "${IMAGE_BASENAME}.${MACHINE}.wks"
9WKS_FILES ?= "${WKS_FILE} ${IMAGE_BASENAME}.wks"
10WKS_SEARCH_PATH ?= "${THISDIR}:${@':'.join('%s/wic' % p for p in '${BBPATH}'.split(':'))}:${@':'.join('%s/scripts/lib/wic/canned-wks' % l for l in '${BBPATH}:${COREBASE}'.split(':'))}"
11WKS_FULL_PATH = "${@wks_search(d.getVar('WKS_FILES').split(), d.getVar('WKS_SEARCH_PATH')) or ''}"
12
13def wks_search(files, search_path):
14 for f in files:
15 if os.path.isabs(f):
16 if os.path.exists(f):
17 return f
18 else:
19 searched = bb.utils.which(search_path, f)
20 if searched:
21 return searched
22
23WIC_CREATE_EXTRA_ARGS ?= ""
24
25IMAGE_CMD_wic () {
26 out="${IMGDEPLOYDIR}/${IMAGE_NAME}"
27 wks="${WKS_FULL_PATH}"
28 if [ -z "$wks" ]; then
29 bbfatal "No kickstart files from WKS_FILES were found: ${WKS_FILES}. Please set WKS_FILE or WKS_FILES appropriately."
30 fi
31
32 BUILDDIR="${TOPDIR}" wic create "$wks" --vars "${STAGING_DIR}/${MACHINE}/imgdata/" -e "${IMAGE_BASENAME}" -o "$out/" ${WIC_CREATE_EXTRA_ARGS}
33 mv "$out/$(basename "${wks%.wks}")"*.direct "$out${IMAGE_NAME_SUFFIX}.wic"
34 rm -rf "$out/"
35}
36IMAGE_CMD_wic[vardepsexclude] = "WKS_FULL_PATH WKS_FILES TOPDIR"
37
38# Rebuild when the wks file or vars in WICVARS change
39USING_WIC = "${@bb.utils.contains_any('IMAGE_FSTYPES', 'wic ' + ' '.join('wic.%s' % c for c in '${CONVERSIONTYPES}'.split()), '1', '', d)}"
40WKS_FILE_CHECKSUM = "${@'${WKS_FULL_PATH}:%s' % os.path.exists('${WKS_FULL_PATH}') if '${USING_WIC}' else ''}"
41do_image_wic[file-checksums] += "${WKS_FILE_CHECKSUM}"
42do_image_wic[depends] += "wic-tools:do_populate_sysroot"
43WKS_FILE_DEPENDS ??= ''
44DEPENDS += "${@ '${WKS_FILE_DEPENDS}' if d.getVar('USING_WIC') else '' }"
45
46python do_write_wks_template () {
47 """Write out expanded template contents to WKS_FULL_PATH."""
48 import re
49
50 template_body = d.getVar('_WKS_TEMPLATE')
51
52 # Remove any remnant variable references left behind by the expansion
53 # due to undefined variables
54 expand_var_regexp = re.compile(r"\${[^{}@\n\t :]+}")
55 while True:
56 new_body = re.sub(expand_var_regexp, '', template_body)
57 if new_body == template_body:
58 break
59 else:
60 template_body = new_body
61
62 wks_file = d.getVar('WKS_FULL_PATH')
63 with open(wks_file, 'w') as f:
64 f.write(template_body)
65}
66
67python () {
68 if d.getVar('USING_WIC'):
69 wks_file_u = d.getVar('WKS_FULL_PATH', False)
70 wks_file = d.expand(wks_file_u)
71 base, ext = os.path.splitext(wks_file)
72 if ext == '.in' and os.path.exists(wks_file):
73 wks_out_file = os.path.join(d.getVar('WORKDIR'), os.path.basename(base))
74 d.setVar('WKS_FULL_PATH', wks_out_file)
75 d.setVar('WKS_TEMPLATE_PATH', wks_file_u)
76 d.setVar('WKS_FILE_CHECKSUM', '${WKS_TEMPLATE_PATH}:True')
77
78 # We need to re-parse each time the file changes, and bitbake
79 # needs to be told about that explicitly.
80 bb.parse.mark_dependency(d, wks_file)
81
82 try:
83 with open(wks_file, 'r') as f:
84 body = f.read()
85 except (IOError, OSError) as exc:
86 pass
87 else:
88 # Previously, I used expandWithRefs to get the dependency list
89 # and add it to WICVARS, but there's no point re-parsing the
90 # file in process_wks_template as well, so just put it in
91 # a variable and let the metadata deal with the deps.
92 d.setVar('_WKS_TEMPLATE', body)
93 bb.build.addtask('do_write_wks_template', 'do_image_wic', None, d)
94}
95
96#
97# Write environment variables used by wic
98# to tmp/sysroots/<machine>/imgdata/<image>.env
99#
100python do_rootfs_wicenv () {
101 wicvars = d.getVar('WICVARS')
102 if not wicvars:
103 return
104
105 stdir = d.getVar('STAGING_DIR')
106 outdir = os.path.join(stdir, d.getVar('MACHINE'), 'imgdata')
107 bb.utils.mkdirhier(outdir)
108 basename = d.getVar('IMAGE_BASENAME')
109 with open(os.path.join(outdir, basename) + '.env', 'w') as envf:
110 for var in wicvars.split():
111 value = d.getVar(var)
112 if value:
113 envf.write('%s="%s"\n' % (var, value.strip()))
114}
115addtask do_rootfs_wicenv after do_image before do_image_wic
116do_rootfs_wicenv[vardeps] += "${WICVARS}"
117do_rootfs_wicenv[prefuncs] = 'set_image_size'