blob: 1ca0756c495958f3764854f8aef369b180cde4dc [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# remove tasks that modify the source tree in case externalsrc is inherited
Patrick Williamsc0f7c042017-02-23 20:41:17 -06002SRCTREECOVEREDTASKS += "do_kernel_configme do_validate_branches do_kernel_configcheck do_kernel_checkout do_fetch do_unpack do_patch"
3PATCH_GIT_USER_EMAIL ?= "kernel-yocto@oe"
4PATCH_GIT_USER_NAME ?= "OpenEmbedded"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005
6# returns local (absolute) path names for all valid patches in the
7# src_uri
8def find_patches(d):
9 patches = src_patches(d)
10 patch_list=[]
11 for p in patches:
12 _, _, local, _, _, _ = bb.fetch.decodeurl(p)
13 patch_list.append(local)
14
15 return patch_list
16
17# returns all the elements from the src uri that are .scc files
18def find_sccs(d):
19 sources=src_patches(d, True)
20 sources_list=[]
21 for s in sources:
22 base, ext = os.path.splitext(os.path.basename(s))
23 if ext and ext in [".scc", ".cfg"]:
24 sources_list.append(s)
25 elif base and base in 'defconfig':
26 sources_list.append(s)
27
28 return sources_list
29
30# check the SRC_URI for "kmeta" type'd git repositories. Return the name of
31# the repository as it will be found in WORKDIR
32def find_kernel_feature_dirs(d):
33 feature_dirs=[]
34 fetch = bb.fetch2.Fetch([], d)
35 for url in fetch.urls:
36 urldata = fetch.ud[url]
37 parm = urldata.parm
38 type=""
39 if "type" in parm:
40 type = parm["type"]
41 if "destsuffix" in parm:
42 destdir = parm["destsuffix"]
43 if type == "kmeta":
44 feature_dirs.append(destdir)
45
46 return feature_dirs
47
48# find the master/machine source branch. In the same way that the fetcher proceses
49# git repositories in the SRC_URI we take the first repo found, first branch.
50def get_machine_branch(d, default):
51 fetch = bb.fetch2.Fetch([], d)
52 for url in fetch.urls:
53 urldata = fetch.ud[url]
54 parm = urldata.parm
55 if "branch" in parm:
56 branches = urldata.parm.get("branch").split(',')
Patrick Williamsf1e5d692016-03-30 15:21:19 -050057 btype = urldata.parm.get("type")
58 if btype != "kmeta":
59 return branches[0]
Patrick Williamsc124f4f2015-09-15 14:41:29 -050060
61 return default
62
63do_kernel_metadata() {
64 set +e
65 cd ${S}
66 export KMETA=${KMETA}
67
68 # if kernel tools are available in-tree, they are preferred
69 # and are placed on the path before any external tools. Unless
70 # the external tools flag is set, in that case we do nothing.
71 if [ -f "${S}/scripts/util/configme" ]; then
72 if [ -z "${EXTERNAL_KERNEL_TOOLS}" ]; then
73 PATH=${S}/scripts/util:${PATH}
74 fi
75 fi
76
77 machine_branch="${@ get_machine_branch(d, "${KBRANCH}" )}"
78 machine_srcrev="${SRCREV_machine}"
79 if [ -z "${machine_srcrev}" ]; then
80 # fallback to SRCREV if a non machine_meta tree is being built
81 machine_srcrev="${SRCREV}"
82 fi
83
84 # In a similar manner to the kernel itself:
85 #
86 # defconfig: $(obj)/conf
87 # ifeq ($(KBUILD_DEFCONFIG),)
88 # $< --defconfig $(Kconfig)
89 # else
90 # @echo "*** Default configuration is based on '$(KBUILD_DEFCONFIG)'"
91 # $(Q)$< --defconfig=arch/$(SRCARCH)/configs/$(KBUILD_DEFCONFIG) $(Kconfig)
92 # endif
93 #
94 # If a defconfig is specified via the KBUILD_DEFCONFIG variable, we copy it
95 # from the source tree, into a common location and normalized "defconfig" name,
96 # where the rest of the process will include and incoroporate it into the build
97 #
98 # If the fetcher has already placed a defconfig in WORKDIR (from the SRC_URI),
99 # we don't overwrite it, but instead warn the user that SRC_URI defconfigs take
100 # precendence.
101 #
102 if [ -n "${KBUILD_DEFCONFIG}" ]; then
103 if [ -f "${S}/arch/${ARCH}/configs/${KBUILD_DEFCONFIG}" ]; then
104 if [ -f "${WORKDIR}/defconfig" ]; then
105 # If the two defconfig's are different, warn that we didn't overwrite the
106 # one already placed in WORKDIR by the fetcher.
107 cmp "${WORKDIR}/defconfig" "${S}/arch/${ARCH}/configs/${KBUILD_DEFCONFIG}"
108 if [ $? -ne 0 ]; then
109 bbwarn "defconfig detected in WORKDIR. ${KBUILD_DEFCONFIG} skipped"
110 fi
111 else
112 cp -f ${S}/arch/${ARCH}/configs/${KBUILD_DEFCONFIG} ${WORKDIR}/defconfig
113 sccs="${WORKDIR}/defconfig"
114 fi
115 else
116 bbfatal "A KBUILD_DECONFIG '${KBUILD_DEFCONFIG}' was specified, but not present in the source tree"
117 fi
118 fi
119
120 sccs="$sccs ${@" ".join(find_sccs(d))}"
121 patches="${@" ".join(find_patches(d))}"
122 feat_dirs="${@" ".join(find_kernel_feature_dirs(d))}"
123
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500124 # check for feature directories/repos/branches that were part of the
125 # SRC_URI. If they were supplied, we convert them into include directives
126 # for the update part of the process
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600127 for f in ${feat_dirs}; do
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500128 if [ -d "${WORKDIR}/$f/meta" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600129 includes="$includes -I${WORKDIR}/$f/kernel-meta"
130 elif [ -d "${WORKDIR}/$f" ]; then
131 includes="$includes -I${WORKDIR}/$f"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500132 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600133 done
134 for s in ${sccs} ${patches}; do
135 sdir=$(dirname $s)
136 includes="$includes -I${sdir}"
137 # if a SRC_URI passed patch or .scc has a subdir of "kernel-meta",
138 # then we add it to the search path
139 if [ -d "${sdir}/kernel-meta" ]; then
140 includes="$includes -I${sdir}/kernel-meta"
141 fi
142 done
143
144 # expand kernel features into their full path equivalents
145 bsp_definition=$(spp ${includes} --find -DKMACHINE=${KMACHINE} -DKTYPE=${LINUX_KERNEL_TYPE})
146 meta_dir=$(kgit --meta)
147
148 # run1: pull all the configuration fragments, no matter where they come from
149 elements="`echo -n ${bsp_definition} ${sccs} ${patches} ${KERNEL_FEATURES}`"
150 if [ -n "${elements}" ]; then
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500151 echo "${bsp_definition}" > ${S}/${meta_dir}/bsp_definition
152 scc --force -o ${S}/${meta_dir}:cfg,merge,meta ${includes} ${bsp_definition} ${sccs} ${patches} ${KERNEL_FEATURES}
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500153 if [ $? -ne 0 ]; then
154 bbfatal_log "Could not generate configuration queue for ${KMACHINE}."
155 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500156 fi
157
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600158 # run2: only generate patches for elements that have been passed on the SRC_URI
159 elements="`echo -n ${sccs} ${patches} ${KERNEL_FEATURES}`"
160 if [ -n "${elements}" ]; then
161 scc --force -o ${S}/${meta_dir}:patch --cmds patch ${includes} ${sccs} ${patches} ${KERNEL_FEATURES}
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500162 if [ $? -ne 0 ]; then
163 bbfatal_log "Could not generate configuration queue for ${KMACHINE}."
164 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500165 fi
166}
167
168do_patch() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500169 set +e
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500170 cd ${S}
171
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600172 check_git_config
173 meta_dir=$(kgit --meta)
174 (cd ${meta_dir}; ln -sf patch.queue series)
175 if [ -f "${meta_dir}/series" ]; then
176 kgit-s2q --gen -v --patches .kernel-meta/
177 if [ $? -ne 0 ]; then
178 bberror "Could not apply patches for ${KMACHINE}."
179 bbfatal_log "Patch failures can be resolved in the linux source directory ${S})"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500180 fi
181 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500182
183 if [ -f "${meta_dir}/merge.queue" ]; then
184 # we need to merge all these branches
185 for b in $(cat ${meta_dir}/merge.queue); do
186 git show-ref --verify --quiet refs/heads/${b}
187 if [ $? -eq 0 ]; then
188 bbnote "Merging branch ${b}"
189 git merge -q --no-ff -m "Merge branch ${b}" ${b}
190 else
191 bbfatal "branch ${b} does not exist, cannot merge"
192 fi
193 done
194 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500195}
196
197do_kernel_checkout() {
198 set +e
199
200 source_dir=`echo ${S} | sed 's%/$%%'`
201 source_workdir="${WORKDIR}/git"
202 if [ -d "${WORKDIR}/git/" ]; then
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500203 # case: git repository
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500204 # if S is WORKDIR/git, then we shouldn't be moving or deleting the tree.
205 if [ "${source_dir}" != "${source_workdir}" ]; then
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500206 if [ -d "${source_workdir}/.git" ]; then
207 # regular git repository with .git
208 rm -rf ${S}
209 mv ${WORKDIR}/git ${S}
210 else
211 # create source for bare cloned git repository
212 git clone ${WORKDIR}/git ${S}
213 rm -rf ${WORKDIR}/git
214 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500215 fi
216 cd ${S}
217 else
218 # case: we have no git repository at all.
219 # To support low bandwidth options for building the kernel, we'll just
220 # convert the tree to a git repo and let the rest of the process work unchanged
221
222 # if ${S} hasn't been set to the proper subdirectory a default of "linux" is
223 # used, but we can't initialize that empty directory. So check it and throw a
224 # clear error
225
226 cd ${S}
227 if [ ! -f "Makefile" ]; then
228 bberror "S is not set to the linux source directory. Check "
229 bbfatal "the recipe and set S to the proper extracted subdirectory"
230 fi
231 rm -f .gitignore
232 git init
233 git add .
234 git commit -q -m "baseline commit: creating repo for ${PN}-${PV}"
235 git clean -d -f
236 fi
237
238 # convert any remote branches to local tracking ones
239 for i in `git branch -a --no-color | grep remotes | grep -v HEAD`; do
240 b=`echo $i | cut -d' ' -f2 | sed 's%remotes/origin/%%'`;
241 git show-ref --quiet --verify -- "refs/heads/$b"
242 if [ $? -ne 0 ]; then
243 git branch $b $i > /dev/null
244 fi
245 done
246
247 # Create a working tree copy of the kernel by checking out a branch
248 machine_branch="${@ get_machine_branch(d, "${KBRANCH}" )}"
249
250 # checkout and clobber any unimportant files
251 git checkout -f ${machine_branch}
252}
253do_kernel_checkout[dirs] = "${S}"
254
255addtask kernel_checkout before do_kernel_metadata after do_unpack
256addtask kernel_metadata after do_validate_branches do_unpack before do_patch
257do_kernel_metadata[depends] = "kern-tools-native:do_populate_sysroot"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500258do_validate_branches[depends] = "kern-tools-native:do_populate_sysroot"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500259
260do_kernel_configme[dirs] += "${S} ${B}"
261do_kernel_configme() {
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600262 set +e
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500263
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600264 # translate the kconfig_mode into something that merge_config.sh
265 # understands
266 case ${KCONFIG_MODE} in
267 *allnoconfig)
268 config_flags="-n"
269 ;;
270 *alldefconfig)
271 config_flags=""
272 ;;
273 *)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500274 if [ -f ${WORKDIR}/defconfig ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600275 config_flags="-n"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500276 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600277 ;;
278 esac
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500279
280 cd ${S}
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600281
282 meta_dir=$(kgit --meta)
283 configs="$(scc --configs -o ${meta_dir})"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500284 if [ $? -ne 0 ]; then
285 bberror "${configs}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600286 bbfatal_log "Could not find configuration queue (${meta_dir}/config.queue)"
287 fi
288
289 CFLAGS="${CFLAGS} ${TOOLCHAIN_OPTIONS}" ARCH=${ARCH} merge_config.sh -O ${B} ${config_flags} ${configs} > ${meta_dir}/cfg/merge_config_build.log 2>&1
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500290 if [ $? -ne 0 ]; then
291 bbfatal_log "Could not configure ${KMACHINE}-${LINUX_KERNEL_TYPE}"
292 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600293
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500294 echo "# Global settings from linux recipe" >> ${B}/.config
295 echo "CONFIG_LOCALVERSION="\"${LINUX_VERSION_EXTENSION}\" >> ${B}/.config
296}
297
298addtask kernel_configme before do_configure after do_patch
299
300python do_kernel_configcheck() {
301 import re, string, sys
302
303 # if KMETA isn't set globally by a recipe using this routine, we need to
304 # set the default to 'meta'. Otherwise, kconf_check is not passed a valid
305 # meta-series for processing
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500306 kmeta = d.getVar("KMETA") or "meta"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500307 if not os.path.exists(kmeta):
308 kmeta = "." + kmeta
309
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500310 pathprefix = "export PATH=%s:%s; " % (d.getVar('PATH'), "${S}/scripts/util/")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600311
312 cmd = d.expand("scc --configs -o ${S}/.kernel-meta")
313 ret, configs = oe.utils.getstatusoutput("%s%s" % (pathprefix, cmd))
314
315 cmd = d.expand("cd ${S}; kconf_check --report -o ${S}/%s/cfg/ ${B}/.config ${S} %s" % (kmeta,configs))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500316 ret, result = oe.utils.getstatusoutput("%s%s" % (pathprefix, cmd))
317
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500318 config_check_visibility = int(d.getVar("KCONF_AUDIT_LEVEL") or 0)
319 bsp_check_visibility = int(d.getVar("KCONF_BSP_AUDIT_LEVEL") or 0)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500320
321 # if config check visibility is non-zero, report dropped configuration values
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600322 mismatch_file = d.expand("${S}/%s/cfg/mismatch.txt" % kmeta)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500323 if os.path.exists(mismatch_file):
324 if config_check_visibility:
325 with open (mismatch_file, "r") as myfile:
326 results = myfile.read()
327 bb.warn( "[kernel config]: specified values did not make it into the kernel's final configuration:\n\n%s" % results)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500328}
329
330# Ensure that the branches (BSP and meta) are on the locations specified by
331# their SRCREV values. If they are NOT on the right commits, the branches
332# are corrected to the proper commit.
333do_validate_branches() {
334 set +e
335 cd ${S}
336
337 machine_branch="${@ get_machine_branch(d, "${KBRANCH}" )}"
338 machine_srcrev="${SRCREV_machine}"
339
340 # if SRCREV is AUTOREV it shows up as AUTOINC there's nothing to
341 # check and we can exit early
342 if [ "${machine_srcrev}" = "AUTOINC" ]; then
343 bbnote "SRCREV validation is not required for AUTOREV"
344 elif [ "${machine_srcrev}" = "" ]; then
345 if [ "${SRCREV}" != "AUTOINC" ] && [ "${SRCREV}" != "INVALID" ]; then
346 # SRCREV_machine_<MACHINE> was not set. This means that a custom recipe
347 # that doesn't use the SRCREV_FORMAT "machine_meta" is being built. In
348 # this case, we need to reset to the give SRCREV before heading to patching
349 bbnote "custom recipe is being built, forcing SRCREV to ${SRCREV}"
350 force_srcrev="${SRCREV}"
351 fi
352 else
353 git cat-file -t ${machine_srcrev} > /dev/null
354 if [ $? -ne 0 ]; then
355 bberror "${machine_srcrev} is not a valid commit ID."
356 bbfatal_log "The kernel source tree may be out of sync"
357 fi
358 force_srcrev=${machine_srcrev}
359 fi
360
361 git checkout -q -f ${machine_branch}
362 if [ -n "${force_srcrev}" ]; then
363 # see if the branch we are about to patch has been properly reset to the defined
364 # SRCREV .. if not, we reset it.
365 branch_head=`git rev-parse HEAD`
366 if [ "${force_srcrev}" != "${branch_head}" ]; then
367 current_branch=`git rev-parse --abbrev-ref HEAD`
368 git branch "$current_branch-orig"
369 git reset --hard ${force_srcrev}
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500370 # We've checked out HEAD, make sure we cleanup kgit-s2q fence post check
371 # so the patches are applied as expected otherwise no patching
372 # would be done in some corner cases.
373 kgit-s2q --clean
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500374 fi
375 fi
376}
377
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500378OE_TERMINAL_EXPORTS += "KBUILD_OUTPUT"
379KBUILD_OUTPUT = "${B}"
380
381python () {
382 # If diffconfig is available, ensure it runs after kernel_configme
383 if 'do_diffconfig' in d:
384 bb.build.addtask('do_diffconfig', None, 'do_kernel_configme', d)
385}