blob: 7fa4a849ead51137f500166f3cc0f88cf46abc7e [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001def __note(msg, d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -05002 bb.note("%s: recipe_sanity: %s" % (d.getVar("P"), msg))
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003
4__recipe_sanity_badruntimevars = "RDEPENDS RPROVIDES RRECOMMENDS RCONFLICTS"
5def bad_runtime_vars(cfgdata, d):
6 if bb.data.inherits_class("native", d) or \
7 bb.data.inherits_class("cross", d):
8 return
9
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 for var in d.getVar("__recipe_sanity_badruntimevars").split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -060011 val = d.getVar(var, False)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012 if val and val != cfgdata.get(var):
13 __note("%s should be %s_${PN}" % (var, var), d)
14
15__recipe_sanity_reqvars = "DESCRIPTION"
16__recipe_sanity_reqdiffvars = ""
17def req_vars(cfgdata, d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018 for var in d.getVar("__recipe_sanity_reqvars").split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -060019 if not d.getVar(var, False):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020 __note("%s should be set" % var, d)
21
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022 for var in d.getVar("__recipe_sanity_reqdiffvars").split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -060023 val = d.getVar(var, False)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024 cfgval = cfgdata.get(var)
25
26 if not val:
27 __note("%s should be set" % var, d)
28 elif val == cfgval:
29 __note("%s should be defined to something other than default (%s)" % (var, cfgval), d)
30
31def var_renames_overwrite(cfgdata, d):
Patrick Williamsc0f7c042017-02-23 20:41:17 -060032 renames = d.getVar("__recipe_sanity_renames", False)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033 if renames:
34 for (key, newkey, oldvalue, newvalue) in renames:
35 if oldvalue != newvalue and oldvalue != cfgdata.get(newkey):
36 __note("rename of variable '%s' to '%s' overwrote existing value '%s' with '%s'." % (key, newkey, oldvalue, newvalue), d)
37
38def incorrect_nonempty_PACKAGES(cfgdata, d):
39 if bb.data.inherits_class("native", d) or \
40 bb.data.inherits_class("cross", d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041 if d.getVar("PACKAGES"):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042 return True
43
44def can_use_autotools_base(cfgdata, d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050045 cfg = d.getVar("do_configure")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050046 if not bb.data.inherits_class("autotools", d):
47 return False
48
49 for i in ["autoreconf"] + ["%s_do_configure" % cls for cls in ["gnomebase", "gnome", "e", "autotools", "efl", "gpephone", "openmoko", "openmoko2", "xfce", "xlibs"]]:
50 if cfg.find(i) != -1:
51 return False
52
Patrick Williamsc0f7c042017-02-23 20:41:17 -060053 for clsfile in d.getVar("__inherit_cache", False):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050054 (base, _) = os.path.splitext(os.path.basename(clsfile))
55 if cfg.find("%s_do_configure" % base) != -1:
56 __note("autotools_base usage needs verification, spotted %s_do_configure" % base, d)
57
58 return True
59
60def can_delete_FILESPATH(cfgdata, d):
61 expected = cfgdata.get("FILESPATH")
62 expectedpaths = d.expand(expected)
Patrick Williamsc0f7c042017-02-23 20:41:17 -060063 unexpanded = d.getVar("FILESPATH", False)
Brad Bishop6e60e8b2018-02-01 10:27:11 -050064 filespath = d.getVar("FILESPATH").split(":")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065 filespath = [os.path.normpath(f) for f in filespath if os.path.exists(f)]
66 for fp in filespath:
67 if not fp in expectedpaths:
68 # __note("Path %s in FILESPATH not in the expected paths %s" %
69 # (fp, expectedpaths), d)
70 return False
71 return expected != unexpanded
72
Patrick Williamsc124f4f2015-09-15 14:41:29 -050073def can_delete_others(p, cfgdata, d):
74 for k in ["S", "PV", "PN", "DESCRIPTION", "DEPENDS",
75 "SECTION", "PACKAGES", "EXTRA_OECONF", "EXTRA_OEMAKE"]:
76 #for k in cfgdata:
Patrick Williamsc0f7c042017-02-23 20:41:17 -060077 unexpanded = d.getVar(k, False)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050078 cfgunexpanded = cfgdata.get(k)
79 if not cfgunexpanded:
80 continue
81
82 try:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050083 expanded = d.getVar(k)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084 cfgexpanded = d.expand(cfgunexpanded)
85 except bb.fetch.ParameterError:
86 continue
87
88 if unexpanded != cfgunexpanded and \
89 cfgexpanded == expanded:
90 __note("candidate for removal of %s" % k, d)
91 bb.debug(1, "%s: recipe_sanity: cfg's '%s' and d's '%s' both expand to %s" %
92 (p, cfgunexpanded, unexpanded, expanded))
93
94python do_recipe_sanity () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050095 p = d.getVar("P")
96 p = "%s %s %s" % (d.getVar("PN"), d.getVar("PV"), d.getVar("PR"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050097
98 sanitychecks = [
Patrick Williamsc124f4f2015-09-15 14:41:29 -050099 (can_delete_FILESPATH, "candidate for removal of FILESPATH"),
100 #(can_use_autotools_base, "candidate for use of autotools_base"),
101 (incorrect_nonempty_PACKAGES, "native or cross recipe with non-empty PACKAGES"),
102 ]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600103 cfgdata = d.getVar("__recipe_sanity_cfgdata", False)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500104
105 for (func, msg) in sanitychecks:
106 if func(cfgdata, d):
107 __note(msg, d)
108
109 can_delete_others(p, cfgdata, d)
110 var_renames_overwrite(cfgdata, d)
111 req_vars(cfgdata, d)
112 bad_runtime_vars(cfgdata, d)
113}
114do_recipe_sanity[nostamp] = "1"
115addtask recipe_sanity
116
117do_recipe_sanity_all[nostamp] = "1"
118do_recipe_sanity_all[recrdeptask] = "do_recipe_sanity_all do_recipe_sanity"
119do_recipe_sanity_all () {
120 :
121}
122addtask recipe_sanity_all after do_recipe_sanity
123
124python recipe_sanity_eh () {
125 d = e.data
126
127 cfgdata = {}
128 for k in d.keys():
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600129 if not isinstance(d.getVar(k, False), bb.data_smart.DataSmart):
130 cfgdata[k] = d.getVar(k, False)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500131
132 d.setVar("__recipe_sanity_cfgdata", cfgdata)
133 #d.setVar("__recipe_sanity_cfgdata", d)
134
135 # Sick, very sick..
136 from bb.data_smart import DataSmart
137 old = DataSmart.renameVar
138 def myrename(self, key, newkey):
139 oldvalue = self.getVar(newkey, 0)
140 old(self, key, newkey)
141 newvalue = self.getVar(newkey, 0)
142 if oldvalue:
143 renames = self.getVar("__recipe_sanity_renames", 0) or set()
144 renames.add((key, newkey, oldvalue, newvalue))
145 self.setVar("__recipe_sanity_renames", renames)
146 DataSmart.renameVar = myrename
147}
148addhandler recipe_sanity_eh
149recipe_sanity_eh[eventmask] = "bb.event.ConfigParsed"