blob: 3cd661d543436fb149d84c0f0ae0e905fe24ad4d [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Sets up distcc for compilation on the target device"
2
3LICENSE = "MIT"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005
6SRC_URI = "file://distcc.sh"
7
8S = "${WORKDIR}"
9
10# Default to the host machine for a running qemu session
11DISTCC_HOSTS ?= "192.168.7.1"
12
13do_configure() {
14 sed -i "s%@DISTCC_HOSTS@%${DISTCC_HOSTS}%" distcc.sh
15}
16
17do_install() {
18 install -d ${D}${sysconfdir}/profile.d
19 install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
20}
21
22RDEPENDS_${PN} = "distcc"