blob: e69bf67729d22b947bf1ec0fbc97e1650cb5da8d [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Libcomps is alternative for yum.comps library (which is for managing rpm package groups)."
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "git://github.com/rpm-software-management/libcomps.git \
6 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
7 file://0002-Set-library-installation-path-correctly.patch \
8 file://0001-Make-__comps_objmrtree_all-static-inline.patch \
9 "
10
11PV = "0.1.8+git${SRCPV}"
12SRCREV = "01a4759894cccff64d2561614a58281adf5ce859"
13
14S = "${WORKDIR}/git"
15
16inherit cmake distutils3-base
17
18DEPENDS += "libxml2 expat libcheck"
19
20EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
21OECMAKE_SOURCEPATH = "${S}/libcomps"
22
23BBCLASSEXTEND = "native nativesdk"
24