blob: 476fa6f0743a3ca5658aeb984f1507ec3f0136f4 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Security-focused ELF files checking tool"
2DESCRIPTION = "This is a small set of various PaX aware and related \
3utilities for ELF binaries. It can check ELF binary files and running \
4processes for issues that might be relevant when using ELF binaries \
5along with PaX, such as non-PIC code or executable stack and heap."
6HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9
10SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.xz \
11"
12
13SRC_URI[md5sum] = "a580468318f0ff42edf4a8cd314cc942"
14SRC_URI[sha256sum] = "7f4a7f8db6b4743adde7582fa48992ad01776796fcde030683732f56221337d9"
15
16RDEPENDS_${PN} += "bash"
17
18export GNULIB_OVERRIDES_WINT_T = "0"
19
20do_configure_prepend() {
21 touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README
22}
23
24do_install() {
25 oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
26}
27
28BBCLASSEXTEND = "native"
29
30inherit autotools pkgconfig
31
32PACKAGECONFIG ??= ""
33
34PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap"
35PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp"
36PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools"
37
38EXTRA_OECONF += "--enable-largefile"