blob: b3fd9730dab42276080b97aa99c5e506c506b7dd [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Script-directed dynamic tracing and performance analysis tool for Linux"
2
3require systemtap_git.inc
4
Patrick Williamsc0f7c042017-02-23 20:41:17 -06005DEPENDS = "boost elfutils"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006
Brad Bishop37a0e4d2017-12-04 01:01:44 -05007RDEPENDS_${PN} += "python3-core bash perl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
9EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
10 --without-nss --without-avahi --without-dyninst \
11 --disable-server --disable-grapher --enable-prologues \
Brad Bishop37a0e4d2017-12-04 01:01:44 -050012 --with-python3 --without-python2-probes \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013 ac_cv_prog_have_javac=no \
14 ac_cv_prog_have_jar=no "
15
16STAP_DOCS ?= "--disable-docs --disable-publican --disable-refdocs"
17
18EXTRA_OECONF += "${STAP_DOCS} "
19
Brad Bishop37a0e4d2017-12-04 01:01:44 -050020PACKAGECONFIG ??= "sqlite monitor python3-probes"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060022PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3"
23PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c"
Brad Bishop37a0e4d2017-12-04 01:01:44 -050024PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,python3-setuptools-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025
Brad Bishop37a0e4d2017-12-04 01:01:44 -050026inherit autotools gettext pkgconfig distutils3-base
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028BBCLASSEXTEND = "nativesdk"