blob: ae0818944138e7b9fd40fd75d7ad2945cd054046 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Audio Sample Rate Conversion library"
2HOMEPAGE = "http://www.mega-nerd.com/SRC/"
3SECTION = "libs"
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=336d6faf40fb600bafb0061f4052f1f4 \
6 file://src/samplerate.c;beginline=1;endline=7;md5=5b6982a8c2811c7312c13cccbf55f55e"
7DEPENDS = "libsndfile1"
8PR = "r1"
9
10SRC_URI = "http://www.mega-nerd.com/SRC/libsamplerate-${PV}.tar.gz \
11 file://0001-configure.ac-improve-alsa-handling.patch \
12"
13
14SRC_URI[md5sum] = "2b78ae9fe63b36b9fbb6267fad93f259"
15SRC_URI[sha256sum] = "0a7eb168e2f21353fb6d84da152e4512126f7dc48ccb0be80578c565413444c1"
16
17CVE_PRODUCT = "libsamplerate"
18
19UPSTREAM_CHECK_URI = "http://www.mega-nerd.com/SRC/download.html"
20
21S = "${WORKDIR}/libsamplerate-${PV}"
22
23inherit autotools pkgconfig
24
25# FFTW and ALSA are only used in tests and examples, so they don't affect
26# normal builds. It should be safe to ignore these, but explicitly disabling
27# them adds some extra certainty that builds are deterministic.
28EXTRA_OECONF = "--disable-fftw --disable-alsa"