blob: ecf232f5faa5bdb7c0c37d14073697d210cc918b [file] [log] [blame]
Howard Chiu0eb09a12021-12-09 13:27:04 +08001LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
3
Potin Lai807e2b22022-04-13 11:24:00 +08004inherit allarch systemd obmc-phosphor-systemd
Howard Chiu0eb09a12021-12-09 13:27:04 +08005
6RDEPENDS:${PN} += "bash"
7RDEPENDS:${PN} += "libgpiod-tools"
Potin Lai501f4c72022-06-13 13:23:57 +08008RDEPENDS:${PN} += "bletchley-common-functions"
Potin Lai2f800ca2022-10-21 19:19:25 +08009RDEPENDS:${PN} += "mdio-tools"
Howard Chiu0eb09a12021-12-09 13:27:04 +080010
11SRC_URI += " \
12 file://bletchley-early-sys-init \
13 file://bletchley-sys-init.service \
Potin Lai2f800ca2022-10-21 19:19:25 +080014 file://bletchley-host-state-monitor \
15 file://bletchley-host-state-monitor.service \
Howard Chiu0eb09a12021-12-09 13:27:04 +080016 "
17
18SYSTEMD_PACKAGES = "${PN}"
19SYSTEMD_SERVICE:${PN}:append = " \
20 bletchley-sys-init.service \
Potin Lai2f800ca2022-10-21 19:19:25 +080021 bletchley-host-state-monitor.service \
Howard Chiu0eb09a12021-12-09 13:27:04 +080022 "
23
24do_install() {
25 install -d ${D}${libexecdir}
26 install -m 0755 ${WORKDIR}/bletchley-early-sys-init ${D}${libexecdir}
Potin Lai2f800ca2022-10-21 19:19:25 +080027 install -m 0755 ${WORKDIR}/bletchley-host-state-monitor ${D}${libexecdir}
Howard Chiu0eb09a12021-12-09 13:27:04 +080028}
Potin Lai807e2b22022-04-13 11:24:00 +080029
30SYSTEMD_OVERRIDE:${PN}:bletchley += "bletchley-sys-init.conf:bletchley-sys-init.service.d/bletchley-sys-init.conf"