Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | require wireguard.inc |
| 2 | |
| 3 | SRCREV = "18fbcd68a35a892527345dc5679d0b2d860ee004" |
| 4 | |
| 5 | SRC_URI = "git://git.zx2c4.com/wireguard-linux-compat;protocol=https;branch=master" |
| 6 | |
| 7 | inherit module kernel-module-split |
| 8 | |
| 9 | DEPENDS = "virtual/kernel libmnl" |
| 10 | |
| 11 | # This module requires Linux 3.10 higher and several networking related |
| 12 | # configuration options. For exact kernel requirements visit: |
| 13 | # https://www.wireguard.io/install/#kernel-requirements |
| 14 | |
| 15 | EXTRA_OEMAKE:append = " \ |
| 16 | KERNELDIR=${STAGING_KERNEL_DIR} \ |
| 17 | " |
| 18 | |
| 19 | MAKE_TARGETS = "module" |
| 20 | MODULES_INSTALL_TARGET = "module-install" |
| 21 | |
| 22 | RRECOMMENDS:${PN} = "kernel-module-xt-hashlimit" |
| 23 | MODULE_NAME = "wireguard" |
| 24 | |
| 25 | |
| 26 | # WireGuard has been merged into Linux kernel >= 5.6 and therefore this compatibility module is no longer required. |
| 27 | # OE-core post dunfell has moved to use kernel 5.8 which now means we cant build this module in world builds |
| 28 | # for reference machines e.g. qemu |
| 29 | EXCLUDE_FROM_WORLD = "1" |
| 30 | |