blob: 1b3916d7343bad91944c3919dbe995687b2d16a7 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "IPC library used by GnuPG and GPGME"
2HOMEPAGE = "http://www.gnupg.org/related_software/libassuan/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4
5LICENSE = "GPLv3+ & LGPLv2.1+"
6LICENSE_${PN} = "LGPLv2.1+"
7LICENSE_${PN}-doc = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
9 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
10 file://src/assuan.c;endline=20;md5=0f465544183405055ec179869fc5b5ba \
11 file://src/assuan-defs.h;endline=20;md5=20cd55535260ca1779edae5c7b80b21e"
12
13DEPENDS = "libgpg-error"
14
15UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
16SRC_URI = "${GNUPG_MIRROR}/libassuan/libassuan-${PV}.tar.bz2 \
17 file://libassuan-add-pkgconfig-support.patch"
18
19SRC_URI[md5sum] = "8e01a7c72d3e5d154481230668e6eb5a"
20SRC_URI[sha256sum] = "22843a3bdb256f59be49842abf24da76700354293a066d82ade8134bb5aa2b71"
21
22BINCONFIG = "${bindir}/libassuan-config"
23
24inherit autotools texinfo binconfig-disabled pkgconfig
25
26do_configure_prepend () {
27 # Else these could be used in preference to those in aclocal-copy
28 rm -f ${S}/m4/*.m4
29}
30
31BBCLASSEXTEND = "native"