blob: e2b471965cce9ecb19723259f3df952231f588e5 [file] [log] [blame]
Brad Bishop70436da2015-09-16 14:49:27 -04001SUMMARY = "Phosphor OpenBMC REST framework"
2DESCRIPTION = "Phosphor OpenBMC REST to DBUS daemon."
3HOMEPAGE = "http://github.com/openbmc/rest-dbus"
4PR = "r1"
5
6inherit allarch
7inherit obmc-phosphor-license
8inherit obmc-phosphor-systemd
9
10SYSTEMD_SERVICE_${PN} = "${PN}.service"
11
12RDEPENDS_${PN} += " \
13 python-netserver \
14 python-json \
15 python-dbus \
16 python-xml \
17 "
18SRC_URI += " \
19 git://github.com/openbmc/rest-dbus.git \
20 file://makefile.patch \
21 file://resources-path.patch \
22 file://no-session-bus.patch \
23 "
24
25SRCREV = "9b0e0bab5150ccc4333ce442932f8969f365155e"
26
27S = "${WORKDIR}/git"
28
29do_install() {
30 oe_runmake prefix=${D} install
31}