blob: a5cc546191d413fd5df2fcfec70697ad3ddf2b91 [file] [log] [blame]
Patrick Williams705982a2024-01-12 09:51:57 -06001KBRANCH ?= "v6.5/standard/base"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06002
3require recipes-kernel/linux/linux-yocto.inc
4
5# CVE exclusions
6include recipes-kernel/linux/cve-exclusion.inc
Patrick Williams705982a2024-01-12 09:51:57 -06007include recipes-kernel/linux/cve-exclusion_6.5.inc
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008
Patrick Williams705982a2024-01-12 09:51:57 -06009SRCREV_machine ?= "e53dc7514de7d2fbe0f80547a50c0542928e2d11"
10SRCREV_meta ?= "3b1f87ec237ec3ad9acffb3d75c55efe958085dc"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060011
12# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
13# get the <version>/base branch, which is pure upstream -stable, and the same
14# meta SRCREV as the linux-yocto-standard builds. Select your version using the
15# normal PREFERRED_VERSION settings.
16BBCLASSEXTEND = "devupstream:target"
Patrick Williams705982a2024-01-12 09:51:57 -060017SRCREV_machine:class-devupstream ?= "4631960b4700dd53f5cebb4f7055fd00ccd556ce"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060018PN:class-devupstream = "linux-yocto-upstream"
Patrick Williams705982a2024-01-12 09:51:57 -060019KBRANCH:class-devupstream = "v6.5/base"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060020
21SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH};protocol=https \
Patrick Williams705982a2024-01-12 09:51:57 -060022 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.5;destsuffix=${KMETA};protocol=https"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060023
24LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
Patrick Williams705982a2024-01-12 09:51:57 -060025LINUX_VERSION ?= "6.5.13"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060026
27PV = "${LINUX_VERSION}+git"
28
29KMETA = "kernel-meta"
30KCONF_BSP_AUDIT_LEVEL = "1"
31
32# Functionality flags
33KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
34KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}"
35KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
36KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc", "", d)}"
37KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc", "", d)}"