blob: 85bfdd52898c8c63ce7225dfc6ad66f6643aed95 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Window and compositing manager based on Clutter"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5DEPENDS = " \
6 xserver-xorg-cvt-native \
7 wayland-native \
8 virtual/libx11 \
Patrick Williams169d7bc2024-01-05 11:33:25 -06009 colord \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060010 graphene \
11 gtk4 \
12 gdk-pixbuf \
13 cairo \
14 pango \
15 gsettings-desktop-schemas \
16 json-glib \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060017 libei \
18 libxtst \
19 libxkbfile \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xinerama', '', d)} \
21 xwayland \
22"
23
24
25inherit gnomebase gsettings gobject-introspection gettext features_check
26
Patrick Williams705982a2024-01-12 09:51:57 -060027SRC_URI[archive.sha256sum] = "b78aea7f3e2bec8322a2af0404716be2269905c7d50c04b0b2a71a38814fcd01"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060028
29# x11 is still manadatory - see meson.build
30REQUIRED_DISTRO_FEATURES = "wayland x11 polkit"
31
32# systemd can be replaced by libelogind (not available atow - make systemd
33# mandatory distro feature)
34LOGIND ?= "systemd"
35REQUIRED_DISTRO_FEATURES += "systemd"
36
37# profiler requires sysprof 3.34 which is not willing to build atow
38PACKAGECONFIG ??= " \
39 native-backend \
40 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl glx', '', d)} \
41 sm \
42 startup-notification \
Patrick Williams169d7bc2024-01-05 11:33:25 -060043 gnome-desktop \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060044"
45
46EXTRA_OEMESON += " \
47 -Dtests=false \
48 -Dnative_tests=false \
49 -Dxwayland_path=${bindir}/Xwayland \
50"
51
52# combi-config - see meson_options.txt for more details
53PACKAGECONFIG[native-backend] = "-Dnative_backend=true -Dudev=true, -Dnative_backend=false -Dudev=false, libdrm virtual/libgbm libinput ${LOGIND} virtual/egl virtual/libgles2 udev"
54PACKAGECONFIG[opengl] = "-Dopengl=true, -Dopengl=true, virtual/libgl"
55PACKAGECONFIG[glx] = "-Dglx=true, -Dglx=false"
56PACKAGECONFIG[libdisplay-info] = "-Dlibdisplay_info=true, -Dlibdisplay_info=false, libdisplay-info"
57PACKAGECONFIG[libwacom] = "-Dlibwacom=true, -Dlibwacom=false, libwacom"
58# Remove depending on pipewire-0.2 when mutter is upgraded to 3.36+
59PACKAGECONFIG[remote-desktop] = "-Dremote_desktop=true, -Dremote_desktop=false, pipewire"
Patrick Williams169d7bc2024-01-05 11:33:25 -060060PACKAGECONFIG[gnome-desktop] = "-Dlibgnome_desktop=true, -Dlibgnome_desktop=false, gnome-desktop gnome-settings-daemon"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060061PACKAGECONFIG[sm] = "-Dsm=true, -Dsm=false, libsm"
Patrick Williams169d7bc2024-01-05 11:33:25 -060062PACKAGECONFIG[sound-player] = "-Dsound_player=true, -Dsound_player=false, libcanberra"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060063PACKAGECONFIG[profiler] = "-Dprofiler=true,-Dprofiler=false,sysprof"
64PACKAGECONFIG[startup-notification] = "-Dstartup_notification=true, -Dstartup_notification=false, startup-notification, startup-notification"
65
66MUTTER_API_NAME = "mutter-13"
67
68do_install:prepend() {
69 sed -i -e 's|${B}/||g' ${B}/clutter/clutter/clutter-enum-types.c
70 sed -i -e 's|${B}/||g' ${B}/src/meta-private-enum-types.c
71 sed -i -e 's|${B}/||g' ${B}/src/meta/meta-enum-types.c
72}
73
74do_install:append() {
75 # Add gir links in standard paths. That makes dependents life much easier
76 # to find them
77 install -d ${D}${datadir}/gir-1.0
78 for gir_full in `find ${D}${libdir}/${MUTTER_API_NAME} -name '*.gir'`; do
79 gir=`basename "$gir_full"`
80 ln -sr "${D}${libdir}/${MUTTER_API_NAME}/$gir" "${D}${datadir}/gir-1.0/$gir"
81 done
82}
83
84GSETTINGS_PACKAGE = "${PN}-gsettings"
85
86PACKAGES =+ "${PN}-tests ${PN}-gsettings"
87
88FILES:${PN} += " \
89 ${datadir}/gnome-control-center \
90 ${datadir}/gir-1.0 \
91 ${libdir}/${MUTTER_API_NAME}/lib*${SOLIBS} \
92 ${libdir}/${MUTTER_API_NAME}/*.typelib \
93 ${libdir}/${MUTTER_API_NAME}/plugins \
94"
95
96FILES:${PN}-tests += " \
97 ${datadir}/installed-tests \
98 ${datadir}/${MUTTER_API_NAME}/tests \
99 ${libexecdir}/installed-tests/${MUTTER_API_NAME} \
100"
101
102FILES:${PN}-dev += " \
103 ${libdir}/${MUTTER_API_NAME}/*.gir \
104 ${libdir}/${MUTTER_API_NAME}/lib*.so \
105"
106
Patrick Williams169d7bc2024-01-05 11:33:25 -0600107RDEPENDS:${PN} += "zenity ${PN}-gsettings gsettings-desktop-schemas"
Patrick Williamsac13d5f2023-11-24 18:59:46 -0600108