blob: b788d6fd03d094d7e8204defd5067b68f5c0bb63 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001# Copyright (C) 2015 Igor Santos <igor.santos@aker.com.br>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Universal Ctags"
5DESCRIPTION = "Universal Ctags is a multilanguage reimplementation of the \
6 Unix ctags utility. Ctags generates an index of source code \
7 definitions which is used by numerous editors and utilities \
8 to instantly locate the definitions."
9
10HOMEPAGE = "https://ctags.io/"
11
12LICENSE = "GPL-2.0-only"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
14
15inherit autotools-brokensep pkgconfig manpages
16
Patrick Williams705982a2024-01-12 09:51:57 -060017SRCREV = "e4cb2a0f9ba947d23e526888930bb1487c2cf1d8"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060018SRC_URI = "git://github.com/universal-ctags/ctags;branch=master;protocol=https"
19
20S = "${WORKDIR}/git"
21
22PACKAGECONFIG ??= " \
23 readcmd \
24 xml \
25 json \
26 yaml \
27"
28PACKAGECONFIG[readcmd] = "--enable-readcmd,--disable-readcmd"
29PACKAGECONFIG[etags] = "--enable-etags,--disable-etags"
30PACKAGECONFIG[xml] = "--enable-xml,--disable-xml,libxml2"
31PACKAGECONFIG[json] = "--enable-json,--disable-json,jansson"
32PACKAGECONFIG[seccomp] = "--enable-seccomp,--disable-seccomp,libseccomp"
33PACKAGECONFIG[yaml] = "--enable-yaml,--disable-yaml,libyaml"
34PACKAGECONFIG[manpages] = ",,python3-docutils-native"
35
36BBCLASSEXTEND = "native"