blob: 988a8ee2b1e4965dea3adeaea7bad929b32e7698 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "display dialog boxes from shell scripts"
2DESCRIPTION = "Dialog lets you to present a variety of questions \
3or display messages using dialog boxes from a shell \
4script (or any scripting language)."
5HOMEPAGE = "http://invisible-island.net/dialog/"
6SECTION = "console/utils"
7DEPENDS = "ncurses"
8LICENSE = "LGPL-2.1-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
10
11SRC_URI = "https://invisible-mirror.net/archives/${BPN}/${BP}.tgz"
Patrick Williams705982a2024-01-12 09:51:57 -060012SRC_URI[sha256sum] = "9419eb52b95837312a76ccb26002c5d624fab53abde0859f1c7364179dc0ebad"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060013
14# hardcoded here for use in dialog-static recipe
15S = "${WORKDIR}/dialog-${PV}"
16
17inherit autotools-brokensep pkgconfig
18
19PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
20
21PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11"
22
23EXTRA_OECONF = "--with-ncurses \
24 --disable-rpath-hack"
25
26do_configure() {
27 gnu-configize --force
28 sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure
29 sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure
30 oe_runconf
31}