blob: 3e757e60377f9499bad2e9d31513810731a7a27e [file] [log] [blame]
Patrick Williamse760df82023-05-26 11:10:49 -05001DESCRIPTION = "C++ client for Redis based on hiredis"
2HOMEPAGE = "https://github.com/sewenew/redis-plus-plus"
3SECTION = "libs"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6
7DEPENDS += "hiredis"
8
9SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \
10 file://0001-CMakeLists.txt-fix-substitution-for-static-libs.patch"
Patrick Williams705982a2024-01-12 09:51:57 -060011SRCREV = "ad6baa121f4c6fbc7622d83d606210ac22549c78"
Patrick Williamse760df82023-05-26 11:10:49 -050012
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17# if ssl is enabled for redis-plus-plus it must also be enabled for hiredis
18PACKAGECONFIG ??= "ssl"
19PACKAGECONFIG[ssl] = "-DREDIS_PLUS_PLUS_USE_TLS=ON, -DREDIS_PLUS_PLUS_USE_TLS=OFF, openssl"
20PACKAGECONFIG[test] = "-DREDIS_PLUS_PLUS_BUILD_TEST=ON, -DREDIS_PLUS_PLUS_BUILD_TEST=OFF"
21
22do_install:append() {
23 # To remove absolute path in .cmake found by QA warning [buildpaths]
24 sed -i -e 's|${STAGING_LIBDIR}/libcrypto.so|crypto|g' ${D}${datadir}/cmake/redis++/redis++-targets.cmake
25 sed -i -e 's|${STAGING_LIBDIR}/libssl.so|ssl|g' ${D}${datadir}/cmake/redis++/redis++-targets.cmake
26}