blob: cece68c632786b278c5771a6d6c2b939d58d378d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "TinyXML-2 is a simple, small, efficient, C++ XML parser that can be easily integrating into other programs"
2HOMEPAGE = "http://www.grinninglizard.com/tinyxml2/"
3SECTION = "libs"
4LICENSE = "Zlib"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"
6
Patrick Williams705982a2024-01-12 09:51:57 -06007SRCREV = "321ea883b7190d4e85cae5512a12e5eaa8f8731f"
Patrick Williams8e7b46e2023-05-01 14:19:06 -05008SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https \
9 file://run-ptest"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
11S = "${WORKDIR}/git"
12
Patrick Williams8e7b46e2023-05-01 14:19:06 -050013inherit meson ptest
14
15EXTRA_OEMESON += "${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true', '', d)}"
16
17CXXFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE"
18
19do_install_ptest() {
20 install -Dm 0755 ${B}/xmltest ${D}${PTEST_PATH}/xmltest
21 install -d ${D}${PTEST_PATH}/resources/out
Patrick Williams705982a2024-01-12 09:51:57 -060022 for f in ${S}/resources/*.xml; do
23 install -m 0644 $f ${D}${PTEST_PATH}/resources/
24 done
Patrick Williams8e7b46e2023-05-01 14:19:06 -050025}
Andrew Geissler82c905d2020-04-13 13:39:40 -050026
27BBCLASSEXTEND = "native"