Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "ASGI is a standard for Python asynchronous web apps and servers to communicate with each other, and positioned as an asynchronous successor to WSGI." |
| 2 | HOMEPAGE = "https://pypi.org/project/asgiref/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa" |
| 6 | |
| 7 | SRC_URI += "file://run-ptest \ |
| 8 | " |
| 9 | |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "9e0ce3aa93a819ba5b45120216b23878cf6e8525eb3848653452b4192b92afed" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 11 | |
| 12 | export BUILD_SYS |
| 13 | export HOST_SYS |
| 14 | |
| 15 | inherit pypi ptest setuptools3 |
| 16 | |
| 17 | RDEPENDS:${PN}-ptest += " \ |
| 18 | ${PYTHON_PN}-pytest \ |
| 19 | ${PYTHON_PN}-asyncio \ |
| 20 | ${PYTHON_PN}-io \ |
| 21 | ${PYTHON_PN}-multiprocessing \ |
| 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | install -d ${D}${PTEST_PATH}/tests |
| 26 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 27 | } |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |