blob: 1854e3bcac1a6d499abd068495be10ec95b9044f [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Assign Ethereum transactions and messages with local private keys."
2HOMEPAGE = "https://github.com/ethereum/eth-account"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=16ffc86adf4293d4cfb204e77d62cfe6"
6
7SRC_URI[sha256sum] = "474a2fccf7286230cf66502565f03b536921d7e1fdfceba198e42160e5ac4bc1"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-bitarray \
13 python3-cytoolz \
14 python3-eth-abi \
15 python3-eth-keyfile \
16 python3-eth-rlp \
17 python3-hexbytes \
18"