blob: cc33edd829bd7e31bd31c9db16aaee2063912b18 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY="Pylint is a Python source code analyzer"
2HOMEPAGE= "http://www.pylint.org/"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
5
6SRC_URI += "git://github.com/pylint-dev/pylint;branch=maintenance/3.0.x;protocol=https \
7 file://run-ptest \
8 "
Patrick Williams169d7bc2024-01-05 11:33:25 -06009SRCREV = "1a5ffc1f447b77071ffe18a9c6836c09147ee2ed"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060010
11inherit python_setuptools_build_meta ptest
12
13RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
14 ${PYTHON_PN}-dill \
15 ${PYTHON_PN}-isort \
16 ${PYTHON_PN}-mccabe \
17 ${PYTHON_PN}-numbers \
18 ${PYTHON_PN}-platformdirs \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-json \
21 ${PYTHON_PN}-pkgutil \
22 ${PYTHON_PN}-difflib \
23 ${PYTHON_PN}-netserver \
24 ${PYTHON_PN}-tomlkit \
25 "
26
27RDEPENDS:${PN}-ptest += " \
28 ${PYTHON_PN}-core \
29 ${PYTHON_PN}-git \
30 ${PYTHON_PN}-py \
31 ${PYTHON_PN}-pytest \
32 ${PYTHON_PN}-pytest-benchmark \
33 ${PYTHON_PN}-pytest-runner \
34 ${PYTHON_PN}-pytest-timeout \
35 ${PYTHON_PN}-pytest-xdist \
36 ${PYTHON_PN}-requests \
37 ${PYTHON_PN}-statistics \
38 ${PYTHON_PN}-tomllib \
39 ${PYTHON_PN}-typing-extensions \
40 "
41
42S = "${WORKDIR}/git"
43
44do_install_ptest() {
45 install -d ${D}${PTEST_PATH}/tests
46 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
47 install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
48 sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
Patrick Williams705982a2024-01-12 09:51:57 -060049 # regression_distutil_import_error_73.py fails to run see
50 # https://lists.openembedded.org/g/openembedded-devel/topic/103181847
51 rm ${D}${PTEST_PATH}/tests/functional/r/regression_02/regression_distutil_import_error_73.py
Patrick Williamsac13d5f2023-11-24 18:59:46 -060052}
53
54BBCLASSEXTEND = "native nativesdk"