blob: 2704637d34500522b912b094173d2575e6f67df0 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
2DESCRIPTION = "\
3The PyMongo distribution contains tools for interacting with MongoDB \
4database from Python. The bson package is an implementation of the BSON \
5format for Python. The pymongo package is a native Python driver for \
6MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
7HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
Patrick Williams169d7bc2024-01-05 11:33:25 -060011SRC_URI[sha256sum] = "31dab1f3e1d0cdd57e8df01b645f52d43cc1b653ed3afd535d2891f4fc4f9712"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060012
13inherit pypi setuptools3
14
15PACKAGES =+ "${PYTHON_PN}-bson"
16
17FILES:${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
18
19RDEPENDS:${PYTHON_PN}-bson += " \
20 ${PYTHON_PN}-datetime \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-netclient \
23 ${PYTHON_PN}-numbers \
24 ${PYTHON_PN}-threading \
25"
26
27RDEPENDS:${PN} += " \
28 ${PYTHON_PN}-bson \
29 ${PYTHON_PN}-pprint \
30"