blob: ac6f8e8313138b3e9cafabfb05a7a259d451cca7 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Thin-wrapper around the mock package for easier use with pytest"
2HOMEPAGE = "https://github.com/pytest-dev/pytest-mock/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = " \
5 file://LICENSE;md5=b2ddb1e69238461b7e4ef2a84d874109 \
6"
7
8SRC_URI = " \
9 git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \
10 file://run-ptest \
11 file://0001-test_pytest_mock-skip-args-introspection-tests.patch \
12"
13
14SRCREV = "69adc6f76c1a7baf4e7a728da9eec38741d5783e"
15
16SRC_URI[sha256sum] = "fbbdb085ef7c252a326fd8cdcac0aa3b1333d8811f131bdcc701002e1be7ed4f"
17
18inherit setuptools3 ptest
19
20DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
21
22RDEPENDS:${PN} += " \
23 python3-asyncio \
24 python3-pytest \
25 python3-pytest-asyncio \
26 python3-unittest \
27"
28
29S = "${WORKDIR}/git"
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}/tests
33 cp -rf ${S}/tests ${D}${PTEST_PATH}/
34}