blob: ece92ee3b3cba83df76940c0714bb4c29d04fa03 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "RAR archive reader for Python"
2HOMEPAGE = "https://github.com/markokr/rarfile"
3LICENSE = "ISC"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2f31e224cbf0c29cb6c55f2bae0e165f"
6
7inherit setuptools3
8
9SRC_URI[sha256sum] = "db60b3b5bc1c4bdeb941427d50b606d51df677353385255583847639473eda48"
10
11inherit pypi
12
13PYPI_PACKAGE="rarfile"
14
15RDEPENDS:${PN} += "\
16 p7zip \
17 ${PYTHON_PN}-core \
18 ${PYTHON_PN}-datetime \
19 ${PYTHON_PN}-crypt \
20 ${PYTHON_PN}-io \
21"
22
23BBCLASSEXTEND = "native nativesdk"