blob: 85e48d46942743790d1e1395bcc75f8859c0de6d [file] [log] [blame]
Patrick Williams2a254922023-08-11 09:48:11 -05001SUMMARY = "Python Library for the Device Tree Compiler"
2HOMEPAGE = "https://devicetree.org/"
3DESCRIPTION = "A python library for the Device Tree Compiler, a tool used to manipulate Device Tree files which contain a data structure for describing hardware."
4SECTION = "bootloader"
5LICENSE = "GPL-2.0-only | BSD-2-Clause"
6
7DEPENDS = "flex-native bison-native swig-native python3-setuptools-scm-native libyaml dtc"
8
9SRC_URI = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git;branch=master \
10 file://0001-Revert-libfdt-overlay-make-overlay_get_target-public.patch \
11 "
12
13UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
14
15LIC_FILES_CHKSUM = "file://pylibfdt/libfdt.i;beginline=1;endline=6;md5=afda088c974174a29108c8d80b5dce90"
16
Andrew Geissler5082cc72023-09-11 08:41:39 -040017SRCREV = "039a99414e778332d8f9c04cbd3072e1dcc62798"
Patrick Williams2a254922023-08-11 09:48:11 -050018
Patrick Williams2a254922023-08-11 09:48:11 -050019S = "${WORKDIR}/git"
20
21PYPA_WHEEL = "${S}/dist/libfdt-1.6.2*.whl"
22
23inherit setuptools3 pkgconfig
24
25BBCLASSEXTEND = "native nativesdk"