blob: be2a73c36953b83e3f511eca5f11a26509f54606 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "More routines for operating on iterables, beyond itertools"
Patrick Williams92b42cb2022-09-03 06:53:57 -05002HOMEPAGE = "https://github.com/erikrose/more-itertools"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5"
5
Andrew Geissler5082cc72023-09-11 08:41:39 -04006SRC_URI[sha256sum] = "626c369fa0eb37bac0291bce8259b332fd59ac792fa5497b59837309cd5b114a"
Patrick Williams92b42cb2022-09-03 06:53:57 -05007
8inherit pypi python_flit_core ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-asyncio \
16 "
17
18RDEPENDS:${PN}-ptest += " \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050019 ${PYTHON_PN}-statistics \
Patrick Williams92b42cb2022-09-03 06:53:57 -050020 ${PYTHON_PN}-pytest \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050021 ${PYTHON_PN}-unittest-automake-output \
Patrick Williams92b42cb2022-09-03 06:53:57 -050022 "
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
28
29BBCLASSEXTEND = "native nativesdk"