blob: 5467b793ce0d18c439c9bc988b0e539ace7d8960 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "the blessed package to manage your versions by scm tags"
2HOMEPAGE = "https://pypi.org/project/setuptools-scm/"
3DESCRIPTION = "setuptools_scm handles managing your Python package \
4versions in SCM metadata instead of declaring them as the version \
5argument or in a SCM managed file."
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=838c366f69b72c5df05c96dff79b35f2"
8
9SRC_URI[sha256sum] = "b5f43ff6800669595193fd09891564ee9d1d7dcb196cab4b2506d53a2e1c95c7"
10
11inherit pypi python_setuptools_build_meta
12
13UPSTREAM_CHECK_REGEX = "scm-(?P<pver>.*)\.tar"
14
15DEPENDS += "python3-tomli-native python3-packaging-native python3-typing-extensions-native"
16
17RDEPENDS:${PN} = "\
18 ${PYTHON_PN}-packaging \
19 ${PYTHON_PN}-pip \
20 ${PYTHON_PN}-pyparsing \
21 ${PYTHON_PN}-setuptools \
22 ${PYTHON_PN}-tomli \
23 ${PYTHON_PN}-typing-extensions \
24"
25
26RDEPENDS:${PN}:append:class-target = " \
27 ${PYTHON_PN}-debugger \
28 ${PYTHON_PN}-json \
29"
30
31BBCLASSEXTEND = "native nativesdk"