blob: 870524d2026b18eb4bb0c8a49a1224f75e04f6da [file] [log] [blame]
Andrew Geissler84ad7c52020-06-27 00:00:16 -05001inherit esw python3native
2
3ESW_COMPONENT_SRC = "/ThirdParty/bsp/freertos10_xilinx/src/"
4ESW_COMPONENT_NAME = "libfreertos.a"
5
6DEPENDS += "libxil xilstandalone xilmem dtc-native python3-pyyaml-native python3-dtc-native xiltimer"
7
8do_configure_prepend() {
9 # This script should also not rely on relative paths and such
10 cd ${S}
11 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH}
12}