blob: 676a8a653340ca19ec2d792804369a55200598b8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A suite of security-related network utilities based on \
2the SSH protocol including the ssh client and sshd server"
3DESCRIPTION = "Secure rlogin/rsh/rcp/telnet replacement (OpenSSH) \
4Ssh (Secure Shell) is a program for logging into a remote machine \
5and for executing commands on a remote machine."
6HOMEPAGE = "http://www.openssh.com/"
7SECTION = "console/network"
8LICENSE = "BSD & ISC & MIT"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=18d9e5a8b3dd1790d73502f50426d4d3"
10
11DEPENDS = "zlib openssl virtual/crypt"
12DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
13
14SRC_URI = "http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
15 file://sshd_config \
16 file://ssh_config \
17 file://init \
18 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
19 file://sshd.socket \
20 file://sshd@.service \
21 file://sshdgenkeys.service \
22 file://volatiles.99_sshd \
23 file://run-ptest \
24 file://fix-potential-signed-overflow-in-pointer-arithmatic.patch \
25 file://sshd_check_keys \
26 file://add-test-support-for-busybox.patch \
27 "
Andrew Geissler6ce62a22020-11-30 19:58:47 -060028SRC_URI[sha256sum] = "5a01d22e407eb1c05ba8a8f7c654d388a13e9f226e4ed33bd38748dafa1d2b24"
29
30# This CVE is specific to OpenSSH server, as used in Fedora and Red Hat Enterprise Linux 7
31# and when running in a Kerberos environment. As such it is not relevant to OpenEmbedded
32CVE_CHECK_WHITELIST += "CVE-2014-9278"
Andrew Geissler82c905d2020-04-13 13:39:40 -050033
34PAM_SRC_URI = "file://sshd"
35
36inherit manpages useradd update-rc.d update-alternatives systemd
37
38USERADD_PACKAGES = "${PN}-sshd"
39USERADD_PARAM_${PN}-sshd = "--system --no-create-home --home-dir /var/run/sshd --shell /bin/false --user-group sshd"
40INITSCRIPT_PACKAGES = "${PN}-sshd"
41INITSCRIPT_NAME_${PN}-sshd = "sshd"
42INITSCRIPT_PARAMS_${PN}-sshd = "defaults 9"
43
44SYSTEMD_PACKAGES = "${PN}-sshd"
45SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket"
46
47inherit autotools-brokensep ptest
48
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050049PACKAGECONFIG ??= "rng-tools"
Andrew Geissler82c905d2020-04-13 13:39:40 -050050PACKAGECONFIG[kerberos] = "--with-kerberos5,--without-kerberos5,krb5"
51PACKAGECONFIG[ldns] = "--with-ldns,--without-ldns,ldns"
52PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit"
53PACKAGECONFIG[manpages] = "--with-mantype=man,--with-mantype=cat"
54
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050055# Add RRECOMMENDS to rng-tools for sshd package
56PACKAGECONFIG[rng-tools] = ""
57
Andrew Geissler82c905d2020-04-13 13:39:40 -050058EXTRA_AUTORECONF += "--exclude=aclocal"
59
60# login path is hardcoded in sshd
61EXTRA_OECONF = "'LOGIN_PROGRAM=${base_bindir}/login' \
62 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \
63 --without-zlib-version-check \
64 --with-privsep-path=${localstatedir}/run/sshd \
65 --sysconfdir=${sysconfdir}/ssh \
66 --with-xauth=${bindir}/xauth \
67 --disable-strip \
68 "
69
Andrew Geissler706d5aa2021-02-12 15:55:30 -060070# musl doesn't implement wtmp/utmp
71EXTRA_OECONF_append_libc-musl = " --disable-wtmp"
Andrew Geissler82c905d2020-04-13 13:39:40 -050072
73# Since we do not depend on libbsd, we do not want configure to use it
74# just because it finds libutil.h. But, specifying --disable-libutil
75# causes compile errors, so...
76CACHED_CONFIGUREVARS += "ac_cv_header_bsd_libutil_h=no ac_cv_header_libutil_h=no"
77
78# passwd path is hardcoded in sshd
79CACHED_CONFIGUREVARS += "ac_cv_path_PATH_PASSWD_PROG=${bindir}/passwd"
80
81# We don't want to depend on libblockfile
82CACHED_CONFIGUREVARS += "ac_cv_header_maillock_h=no"
83
84do_configure_prepend () {
85 export LD="${CC}"
86 install -m 0644 ${WORKDIR}/sshd_config ${B}/
87 install -m 0644 ${WORKDIR}/ssh_config ${B}/
88}
89
90do_compile_ptest() {
91 # skip regress/unittests/ binaries: this will silently skip
92 # unittests in run-ptests which is good because they are so slow.
93 oe_runmake regress/modpipe regress/setuid-allowed regress/netcat \
94 regress/check-perm regress/mkdtemp
95}
96
97do_install_append () {
98 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then
99 install -D -m 0644 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd
100 sed -i -e 's:#UsePAM no:UsePAM yes:' ${D}${sysconfdir}/ssh/sshd_config
101 fi
102
103 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then
104 sed -i -e 's:#X11Forwarding no:X11Forwarding yes:' ${D}${sysconfdir}/ssh/sshd_config
105 fi
106
107 install -d ${D}${sysconfdir}/init.d
108 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/sshd
109 rm -f ${D}${bindir}/slogin ${D}${datadir}/Ssh.bin
110 rmdir ${D}${localstatedir}/run/sshd ${D}${localstatedir}/run ${D}${localstatedir}
111 install -d ${D}/${sysconfdir}/default/volatiles
112 install -m 644 ${WORKDIR}/volatiles.99_sshd ${D}/${sysconfdir}/default/volatiles/99_sshd
113 install -m 0755 ${S}/contrib/ssh-copy-id ${D}${bindir}
114
115 # Create config files for read-only rootfs
116 install -d ${D}${sysconfdir}/ssh
117 install -m 644 ${D}${sysconfdir}/ssh/sshd_config ${D}${sysconfdir}/ssh/sshd_config_readonly
118 sed -i '/HostKey/d' ${D}${sysconfdir}/ssh/sshd_config_readonly
119 echo "HostKey /var/run/ssh/ssh_host_rsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
120 echo "HostKey /var/run/ssh/ssh_host_ecdsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
121 echo "HostKey /var/run/ssh/ssh_host_ed25519_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
122
123 install -d ${D}${systemd_unitdir}/system
124 install -c -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_unitdir}/system
125 install -c -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_unitdir}/system
126 install -c -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_unitdir}/system
127 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
128 -e 's,@SBINDIR@,${sbindir},g' \
129 -e 's,@BINDIR@,${bindir},g' \
130 -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \
131 ${D}${systemd_unitdir}/system/sshd.socket ${D}${systemd_unitdir}/system/*.service
132
133 sed -i -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \
134 ${D}${sysconfdir}/init.d/sshd
135
136 install -D -m 0755 ${WORKDIR}/sshd_check_keys ${D}${libexecdir}/${BPN}/sshd_check_keys
137}
138
139do_install_ptest () {
140 sed -i -e "s|^SFTPSERVER=.*|SFTPSERVER=${libexecdir}/sftp-server|" regress/test-exec.sh
141 cp -r regress ${D}${PTEST_PATH}
142}
143
144ALLOW_EMPTY_${PN} = "1"
145
146PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server"
147FILES_${PN}-scp = "${bindir}/scp.${BPN}"
148FILES_${PN}-ssh = "${bindir}/ssh.${BPN} ${sysconfdir}/ssh/ssh_config"
149FILES_${PN}-sshd = "${sbindir}/sshd ${sysconfdir}/init.d/sshd ${systemd_unitdir}/system"
150FILES_${PN}-sshd += "${sysconfdir}/ssh/moduli ${sysconfdir}/ssh/sshd_config ${sysconfdir}/ssh/sshd_config_readonly ${sysconfdir}/default/volatiles/99_sshd ${sysconfdir}/pam.d/sshd"
151FILES_${PN}-sshd += "${libexecdir}/${BPN}/sshd_check_keys"
152FILES_${PN}-sftp = "${bindir}/sftp"
153FILES_${PN}-sftp-server = "${libexecdir}/sftp-server"
154FILES_${PN}-misc = "${bindir}/ssh* ${libexecdir}/ssh*"
155FILES_${PN}-keygen = "${bindir}/ssh-keygen"
156
157RDEPENDS_${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen"
158RDEPENDS_${PN}-sshd += "${PN}-keygen ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-keyinit pam-plugin-loginuid', '', d)}"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500159RRECOMMENDS_${PN}-sshd_append_class-target = "\
160 ${@bb.utils.filter('PACKAGECONFIG', 'rng-tools', d)} \
161"
162
Andrew Geissler82c905d2020-04-13 13:39:40 -0500163# gdb would make attach-ptrace test pass rather than skip but not worth the build dependencies
164RDEPENDS_${PN}-ptest += "${PN}-sftp ${PN}-misc ${PN}-sftp-server make sed sudo coreutils"
165
166RPROVIDES_${PN}-ssh = "ssh"
167RPROVIDES_${PN}-sshd = "sshd"
168
169RCONFLICTS_${PN} = "dropbear"
170RCONFLICTS_${PN}-sshd = "dropbear"
171
172CONFFILES_${PN}-sshd = "${sysconfdir}/ssh/sshd_config"
173CONFFILES_${PN}-ssh = "${sysconfdir}/ssh/ssh_config"
174
175ALTERNATIVE_PRIORITY = "90"
176ALTERNATIVE_${PN}-scp = "scp"
177ALTERNATIVE_${PN}-ssh = "ssh"
178
179BBCLASSEXTEND += "nativesdk"