blob: 4eb357e31013e5682057999e76cdbd3bdddd10bb [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "The basic file, shell and text manipulation utilities"
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
7LICENSE = "GPLv3+"
Andrew Geissler4b740dc2020-05-05 08:54:39 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
9 file://src/ls.c;beginline=1;endline=15;md5=b7d80abf5b279320fb0e4b1007ed108b \
10 "
Brad Bishopc342db32019-05-15 21:57:59 -040011DEPENDS = "gmp libcap"
12DEPENDS_class-native = ""
13
14inherit autotools gettext texinfo
15
16SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
17 file://remove-usr-local-lib-from-m4.patch \
18 file://fix-selinux-flask.patch \
19 file://0001-uname-report-processor-and-hardware-correctly.patch \
20 file://disable-ls-output-quoting.patch \
21 file://0001-local.mk-fix-cross-compiling-problem.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 file://run-ptest \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050023 file://0001-ls-restore-8.31-behavior-on-removed-directories.patch \
24 "
Brad Bishopc342db32019-05-15 21:57:59 -040025
Andrew Geissler4b740dc2020-05-05 08:54:39 -050026SRC_URI[md5sum] = "022042695b7d5bcf1a93559a9735e668"
27SRC_URI[sha256sum] = "4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa"
Brad Bishopc342db32019-05-15 21:57:59 -040028
29EXTRA_OECONF_class-native = "--without-gmp"
30EXTRA_OECONF_class-target = "--enable-install-program=arch,hostname --libexecdir=${libdir}"
31EXTRA_OECONF_class-nativesdk = "--enable-install-program=arch,hostname"
32
33# acl and xattr are not default features
34#
35PACKAGECONFIG_class-target ??= "\
36 ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \
37"
38
39# The lib/oe/path.py requires xattr
40PACKAGECONFIG_class-native ??= "xattr"
41
42# with, without, depends, rdepends
43#
44PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
45PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
46PACKAGECONFIG[single-binary] = "--enable-single-binary,--disable-single-binary,,"
47
48# [ df mktemp nice printenv base64 gets a special treatment and is not included in this
49bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname du \
50 env expand expr factor fmt fold groups head hostid id install \
51 join link logname md5sum mkfifo nl nohup nproc od paste pathchk \
52 pinky pr printf ptx readlink realpath runcon seq sha1sum sha224sum sha256sum \
Brad Bishop64c979e2019-11-04 13:55:29 -050053 sha384sum sha512sum shred shuf sort split sum tac tail tee test timeout \
Brad Bishopc342db32019-05-15 21:57:59 -040054 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
55
56# hostname gets a special treatment and is not included in this
57base_bindir_progs = "cat chgrp chmod chown cp date dd echo false hostname kill ln ls mkdir \
58 mknod mv pwd rm rmdir sleep stty sync touch true uname stat"
59
60sbindir_progs= "chroot"
61
Andrew Geissler475cb722020-07-10 16:00:51 -050062# Split stdbuf into its own package, so one can include
63# coreutils-stdbuf without getting the rest of coreutils, but make
64# coreutils itself pull in stdbuf, so IMAGE_INSTALL += "coreutils"
65# always provides all coreutils
66PACKAGE_BEFORE_PN_class-target += "${@bb.utils.contains('PACKAGECONFIG', 'single-binary', '', 'coreutils-stdbuf', d)}"
Brad Bishop64c979e2019-11-04 13:55:29 -050067FILES_coreutils-stdbuf = "${bindir}/stdbuf ${libdir}/coreutils/libstdbuf.so"
Andrew Geissler475cb722020-07-10 16:00:51 -050068RDEPENDS_coreutils_class-target += "${@bb.utils.contains('PACKAGECONFIG', 'single-binary', '', 'coreutils-stdbuf', d)}"
69
70# However, when the single-binary PACKAGECONFIG is used, stdbuf
71# functionality is built into the single coreutils binary, so there's
72# no point splitting /usr/bin/stdbuf to its own package. Instead, add
73# an RPROVIDE so that rdepending on coreutils-stdbuf will work
74# regardless of whether single-binary is in effect.
75RPROVIDES_coreutils += "${@bb.utils.contains('PACKAGECONFIG', 'single-binary', 'coreutils-stdbuf', '', d)}"
Brad Bishop64c979e2019-11-04 13:55:29 -050076
Brad Bishopc342db32019-05-15 21:57:59 -040077# Let aclocal use the relative path for the m4 file rather than the
78# absolute since coreutils has a lot of m4 files, otherwise there might
79# be an "Argument list too long" error when it is built in a long/deep
80# directory.
81acpaths = "-I ./m4"
82
83# Deal with a separate builddir failure if src doesn't exist when creating version.c/version.h
84do_compile_prepend () {
85 mkdir -p ${B}/src
86}
87
88do_install_class-native() {
89 autotools_do_install
90 # remove groups to fix conflict with shadow-native
91 rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
92 # The return is a must since native doesn't need the
93 # do_install_append() in the below.
94 return
95}
96
97do_install_append() {
98 for i in df mktemp nice printenv base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
99
100 install -d ${D}${base_bindir}
101 [ "${base_bindir}" != "${bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${BPN}; done
102
103 install -d ${D}${sbindir}
104 [ "${sbindir}" != "${bindir}" ] && for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${BPN}; done
105
106 # [ requires special handling because [.coreutils will cause the sed stuff
107 # in update-alternatives to fail, therefore use lbracket - the name used
108 # for the actual source file.
109 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${BPN}
110}
111
112inherit update-alternatives
113
114ALTERNATIVE_PRIORITY = "100"
115# Make hostname's priority higher than busybox but lower than net-tools
116ALTERNATIVE_PRIORITY[hostname] = "90"
117ALTERNATIVE_${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base64 nice printenv mktemp df"
118ALTERNATIVE_${PN}-doc = "base64.1 nice.1 mktemp.1 df.1 groups.1 kill.1 uptime.1 stat.1 hostname.1"
119
120ALTERNATIVE_LINK_NAME[hostname.1] = "${mandir}/man1/hostname.1"
121
122ALTERNATIVE_LINK_NAME[base64] = "${base_bindir}/base64"
123ALTERNATIVE_TARGET[base64] = "${bindir}/base64.${BPN}"
124ALTERNATIVE_LINK_NAME[base64.1] = "${mandir}/man1/base64.1"
125
126ALTERNATIVE_LINK_NAME[mktemp] = "${base_bindir}/mktemp"
127ALTERNATIVE_TARGET[mktemp] = "${bindir}/mktemp.${BPN}"
128ALTERNATIVE_LINK_NAME[mktemp.1] = "${mandir}/man1/mktemp.1"
129
130ALTERNATIVE_LINK_NAME[df] = "${base_bindir}/df"
131ALTERNATIVE_TARGET[df] = "${bindir}/df.${BPN}"
132ALTERNATIVE_LINK_NAME[df.1] = "${mandir}/man1/df.1"
133
134ALTERNATIVE_LINK_NAME[nice] = "${base_bindir}/nice"
135ALTERNATIVE_TARGET[nice] = "${bindir}/nice.${BPN}"
136ALTERNATIVE_LINK_NAME[nice.1] = "${mandir}/man1/nice.1"
137
138ALTERNATIVE_LINK_NAME[printenv] = "${base_bindir}/printenv"
139ALTERNATIVE_TARGET[printenv] = "${bindir}/printenv.${BPN}"
140
141ALTERNATIVE_LINK_NAME[lbracket] = "${bindir}/["
142ALTERNATIVE_TARGET[lbracket] = "${bindir}/lbracket.${BPN}"
143
144ALTERNATIVE_LINK_NAME[groups.1] = "${mandir}/man1/groups.1"
145ALTERNATIVE_LINK_NAME[uptime.1] = "${mandir}/man1/uptime.1"
146ALTERNATIVE_LINK_NAME[kill.1] = "${mandir}/man1/kill.1"
147ALTERNATIVE_LINK_NAME[stat.1] = "${mandir}/man1/stat.1"
148
149python __anonymous() {
150 for prog in d.getVar('base_bindir_progs').split():
151 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir'), prog))
152
153 for prog in d.getVar('sbindir_progs').split():
154 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('sbindir'), prog))
155}
156
157BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500158
159inherit ptest
160
Andrew Geisslerf0343792020-11-18 10:42:21 -0600161RDEPENDS_${PN}-ptest += "bash findutils gawk liberror-perl make perl perl-modules python3-core sed shadow"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500162
163# -dev automatic dependencies fails as we don't want libmodule-build-perl-dev, its too heavy
164# may need tweaking if DEPENDS changes
165RRECOMMENDS_coreutils-dev[nodeprrecs] = "1"
166RRECOMMENDS_coreutils-dev = "acl-dev attr-dev gmp-dev libcap-dev bash-dev findutils-dev gawk-dev shadow-dev"
167
168do_install_ptest () {
169 install -d ${D}${PTEST_PATH}/tests
170 cp -r ${S}/tests/* ${D}${PTEST_PATH}/tests
171 sed -i 's/ginstall/install/g' `grep -R ginstall ${D}${PTEST_PATH}/tests | awk -F: '{print $1}' | uniq`
172 install -d ${D}${PTEST_PATH}/build-aux
173 install ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
174 cp ${B}/Makefile ${D}${PTEST_PATH}/
175 cp ${S}/init.cfg ${D}${PTEST_PATH}/
176 cp -r ${B}/src ${D}${PTEST_PATH}/
177 cp -r ${S}/src/*.c ${D}${PTEST_PATH}/src
178 sed -i '/^VPATH/s/= .*$/= ./g' ${D}${PTEST_PATH}/Makefile
179 sed -i '/^PROGRAMS/s/^/#/g' ${D}${PTEST_PATH}/Makefile
180 sed -i '/^Makefile: /s/^.*$/Makefile:/g' ${D}${PTEST_PATH}/Makefile
181 sed -i '/^abs_srcdir/s/= .*$/= \$\{PWD\}/g' ${D}${PTEST_PATH}/Makefile
182 sed -i '/^abs_top_builddir/s/= .*$/= \$\{PWD\}/g' ${D}${PTEST_PATH}/Makefile
183 sed -i '/^abs_top_srcdir/s/= .*$/= \$\{PWD\}/g' ${D}${PTEST_PATH}/Makefile
184 sed -i '/^built_programs/s/ginstall/install/g' ${D}${PTEST_PATH}/Makefile
185 chmod -R 777 ${D}${PTEST_PATH}
186
187 # Disable subcase stty-pairs.sh, it will cause test framework hang
188 sed -i '/stty-pairs.sh/d' ${D}${PTEST_PATH}/Makefile
189
190 # Disable subcase tail-2/assert.sh as it has issues on 32-bit systems
191 sed -i '/assert.sh/d' ${D}${PTEST_PATH}/Makefile
192
193 # Tweak test d_type-check to use python3 instead of python
194 sed -i "1s@.*@#!/usr/bin/python3@" ${D}${PTEST_PATH}/tests/d_type-check
195 install ${B}/src/getlimits ${D}/${bindir}
196
197 # handle multilib
198 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
199}
200
201FILES_${PN}-ptest += "${bindir}/getlimits"
Andrew Geissler09209ee2020-12-13 08:44:15 -0600202
203# These are specific to Opensuse
204CVE_WHITELIST += "CVE-2013-0221 CVE-2013-0222 CVE-2013-0223"