blob: 1f83660856c7255c0708b7b73b4fe32082bfc27b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001require glib.inc
2
3PE = "1"
4
5SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
6
7SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
8 file://run-ptest \
9 file://0001-Fix-DATADIRNAME-on-uclibc-Linux.patch \
10 file://Enable-more-tests-while-cross-compiling.patch \
11 file://0001-Remove-the-warning-about-deprecated-paths-in-schemas.patch \
12 file://0001-Install-gio-querymodules-as-libexec_PROGRAM.patch \
13 file://0001-Do-not-ignore-return-value-of-write.patch \
14 file://0010-Do-not-hardcode-python-path-into-various-tools.patch \
15 file://0001-Set-host_machine-correctly-when-building-with-mingw3.patch \
16 file://0001-Do-not-write-bindir-into-pkg-config-files.patch \
17 file://0001-meson-Run-atomics-test-on-clang-as-well.patch \
18 file://0001-gio-tests-resources.c-comment-out-a-build-host-only-.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050019 "
20
21SRC_URI_append_class-native = " file://relocate-modules.patch"
22
Andrew Geissler706d5aa2021-02-12 15:55:30 -060023SRC_URI[sha256sum] = "ec390bed4e8dd0f89e918f385e8d4cfd7470b1ef7c1ce93ec5c4fc6e3c6a17c4"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25# Find any meson cross files in FILESPATH that are relevant for the current
26# build (using siteinfo) and add them to EXTRA_OEMESON.
27inherit siteinfo
28def find_meson_cross_files(d):
29 if bb.data.inherits_class('native', d):
30 return ""
31
32 corebase = d.getVar("COREBASE")
33 import collections
34 sitedata = siteinfo_data(d)
35 # filename -> found
36 files = collections.OrderedDict()
37 for path in d.getVar("FILESPATH").split(":"):
38 for element in sitedata:
39 filename = os.path.normpath(os.path.join(path, "meson.cross.d", element))
40 files[filename.replace(corebase, "${COREBASE}")] = os.path.exists(filename)
41
42 items = ["--cross-file=" + k for k,v in files.items() if v]
43 d.appendVar("EXTRA_OEMESON", " " + " ".join(items))
44 items = ["%s:%s" % (k, "True" if v else "False") for k,v in files.items()]
45 d.appendVarFlag("do_configure", "file-checksums", " " + " ".join(items))
46
47python () {
48 find_meson_cross_files(d)
49}