blob: 3e7d0ed48d779736ad5f738f05152f5d980eac71 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A meta recipe to build native tools used by wic."
2
3LICENSE = "MIT"
4
5DEPENDS = "\
Andrew Geissler706d5aa2021-02-12 15:55:30 -06006 parted-native syslinux-native gptfdisk-native dosfstools-native \
Andrew Geisslerd25ed322020-06-27 00:28:28 -05007 mtools-native bmap-tools-native grub-native cdrtools-native \
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008 btrfs-tools-native squashfs-tools-native pseudo-native \
Andrew Geissler82c905d2020-04-13 13:39:40 -05009 e2fsprogs-native util-linux-native tar-native\
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 "
Andrew Geissler706d5aa2021-02-12 15:55:30 -060011DEPENDS_append_x86 = " syslinux grub-efi systemd-boot"
12DEPENDS_append_x86-64 = " syslinux grub-efi systemd-boot"
13DEPENDS_append_x86-x32 = " syslinux grub-efi"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014
15INHIBIT_DEFAULT_DEPS = "1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017inherit nopackages
18
19# The sysroot of wic-tools is needed for wic, but if rm_work is enabled, it will
20# be removed before wic has a chance to use it, hence the exclusion below.
21RM_WORK_EXCLUDE += "${PN}"
22
23python do_build_sysroot () {
24 bb.build.exec_func("extend_recipe_sysroot", d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025}
26addtask do_build_sysroot after do_prepare_recipe_sysroot before do_build