blob: f92c639810438dba980b47120354e07ddb9d71bd [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001require systemd.inc
2FILESEXTRAPATHS =. "${FILE_DIRNAME}/systemd:"
3
4require conf/image-uefi.conf
5
6DEPENDS = "intltool-native libcap util-linux gnu-efi gperf-native"
7
8inherit meson pkgconfig gettext
9inherit deploy
10
11LDFLAGS_prepend = "${@ " ".join(d.getVar('LD').split()[1:])} "
12
13do_write_config[vardeps] += "CC OBJCOPY"
14do_write_config_append() {
15 cat >${WORKDIR}/meson-${PN}.cross <<EOF
16[binaries]
17efi_cc = ${@meson_array('CC', d)}
18objcopy = ${@meson_array('OBJCOPY', d)}
19EOF
20}
21
22EXTRA_OEMESON += "-Defi=true \
23 -Dgnu-efi=true \
24 -Defi-includedir=${STAGING_INCDIR}/efi \
25 -Defi-libdir=${STAGING_LIBDIR} \
26 -Defi-ld=${@ d.getVar('LD').split()[0]} \
27 -Dman=false \
28 --cross-file ${WORKDIR}/meson-${PN}.cross \
29 "
30
31# install to the image as boot*.efi if its the EFI_PROVIDER,
32# otherwise install as the full name.
33# This allows multiple bootloaders to coexist in a single image.
34python __anonymous () {
35 import re
36 target = d.getVar('TARGET_ARCH')
37 prefix = "" if d.getVar('EFI_PROVIDER') == "systemd-boot" else "systemd-"
38 systemdimage = prefix + d.getVar("EFI_BOOT_IMAGE")
39 d.setVar("SYSTEMD_BOOT_IMAGE", systemdimage)
40 prefix = "systemd-" if prefix == "" else ""
41 d.setVar("SYSTEMD_BOOT_IMAGE_PREFIX", prefix)
42}
43
44FILES_${PN} = "${EFI_FILES_PATH}/${SYSTEMD_BOOT_IMAGE}"
45
46RDEPENDS_${PN} += "virtual/systemd-bootconf"
47
48# Imported from the old gummiboot recipe
49TUNE_CCARGS_remove = "-mfpmath=sse"
Andrew Geissler706d5aa2021-02-12 15:55:30 -060050COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
Andrew Geissler82c905d2020-04-13 13:39:40 -050051COMPATIBLE_HOST_x86-x32 = "null"
52
53do_compile() {
Andrew Geissler706d5aa2021-02-12 15:55:30 -060054 SYSTEMD_BOOT_EFI_ARCH="ia32"
55 if [ "${TARGET_ARCH}" = "x86_64" ]; then
56 SYSTEMD_BOOT_EFI_ARCH="x64"
57 fi
58
59 ninja src/boot/efi/${SYSTEMD_BOOT_IMAGE_PREFIX}${SYSTEMD_BOOT_IMAGE}
Andrew Geissler82c905d2020-04-13 13:39:40 -050060}
61
62do_install() {
63 install -d ${D}${EFI_FILES_PATH}
64 install ${B}/src/boot/efi/systemd-boot*.efi ${D}${EFI_FILES_PATH}/${SYSTEMD_BOOT_IMAGE}
65}
66
67do_deploy () {
68 install ${B}/src/boot/efi/systemd-boot*.efi ${DEPLOYDIR}
69}
Andrew Geissler82c905d2020-04-13 13:39:40 -050070addtask deploy before do_build after do_compile