blob: fd004f4c9b3879373d9119da5daf3adb9dabd570 [file] [log] [blame]
Andrew Geissler706d5aa2021-02-12 15:55:30 -06001SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPLv3+"
10LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=22d514dbc01fdf9a9784334b6b59417a"
11
12DEPENDS = "zlib"
13
14SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz"
15SRC_URI[sha256sum] = "34309a59d4b6b6b33756366aa9d3144a4655587be9f914476b4c0e2d36365f01"
16
17UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
18
19inherit autotools
20
21# Remove ccache-native's dependencies, so that it can be used widely by
22# other native recipes.
23DEPENDS_class-native = ""
24EXTRA_OECONF_class-native = "--with-bundled-zlib"
25INHIBIT_AUTOTOOLS_DEPS_class-native = "1"
26PATCHTOOL = "patch"
27
28BBCLASSEXTEND = "native"
29
30do_configure_class-native() {
31 oe_runconf
32}